-2

hi im quite new but have managed to install sip v4.16.9

(precise)cloud12321@localhost:~/Downloads/PyQt-gpl-5/PyQt-gpl-5.5$ sip -V 4.16.9

Now the configure.py went fine. the problem i have is that every time i try to make PyQt5 it gives me these errors:

cd QtCore/ && ( test -e Makefile || /usr/lib/x86_64-linux-gnu/qt5/bin/qmake /home/cloud12321/Downloads/PyQt-gpl-5/PyQt-gpl-5.5/QtCore/QtCore.pro -o Makefile ) && make -f Makefile 
make[1]: Entering directory `/home/cloud12321/Downloads/PyQt-gpl-5/PyQt-gpl-5.5/QtCore'
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQSize.o sipQtCoreQSize.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQFile.o sipQtCoreQFile.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQAbstractAnimation.o sipQtCoreQAbstractAnimation.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQTextEncoder.o sipQtCoreQTextEncoder.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQSortFilterProxyModel.o sipQtCoreQSortFilterProxyModel.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQWriteLocker.o sipQtCoreQWriteLocker.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQList0100QPersistentModelIndex.o sipQtCoreQList0100QPersistentModelIndex.cpp
g++ -c -m64 -pipe -fno-exceptions -O2 -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -I. -I/usr/include/python2.7 -I../qpy/QtCore -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I. -o sipQtCoreQJsonParseError.o sipQtCoreQJsonParseError.cpp
/home/cloud12321/Downloads/PyQt-gpl-5/PyQt-gpl-5.5/QtCore/sipQtCoreQJsonParseError.cpp:147:49: error: 'DocumentTooLarge' is not a member of 'QJsonParseError'
make[1]: *** [sipQtCoreQJsonParseError.o] Error 1
make[1]: Leaving directory `/home/cloud12321/Downloads/PyQt-gpl-5/PyQt-gpl-5.5/QtCore'
make: *** [sub-QtCore-make_first-ordered] Error 2

Can someone please point me in the right direction on what needs to be one to fix these errors?

0

SIP must be installed before building and using PyQt5. You can get the latest release of the SIP source code from here.

The SIP documentation can be found here.

You can get the latest release of the GPL version of the PyQt5 source code from here.

For more informations

  • i already have SIP installed (precise)cloud12321@localhost:~/Downloads/PyQt-gpl-5/PyQt-gpl-5.5$ sip -V 4.16.9 ..... so as you see its installed and i have been to the webpage specified in the bottom of your answer and it has nothing there about the two errors im getting – cloud12321 Sep 29 '15 at 20:06
0

I had the same error. I had Qt 5.0 installed, which comes regularly with Ubuntu 12.04.

To fix it I installed Qt 5.5 (for Ubuntu 12.04 see this instruction) and then passed the corresponding qmake path to the configure.py script using the --qmake flag.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.