I have Windows 7 booted via BIOS(not UEFI) and encrypted by PGP. I would like to have a dual boot installation of Ubuntu on external USB hard-drive. Installation Wizard of Ubuntu does not offer an Alongside option. My guess is it does not see current Windows, since the disk is encrypted.

My booting sequence is - 1st power-on/hdd password(set in BIOS). Then there is an option to boot from another device, then comes PGP screen where I enter the password. Then actually comes Dual boot screen added by Wubi.

Can it be done? How?

  • I don't want to perform a risky operation during which I might corrupt my current Windows installation irreparably. But I have no "moral problem" with using system image recovery.
    – Javo
    Sep 29 '15 at 9:07
  • The closest thing that i could think of is creating a seperate /boot partition for handling encryption and bootloader
    – H. Freeze
    Sep 29 '15 at 9:32
  • I myself haven't ventured in that field too much but i found something over intenet that might help you security.stackexchange.com/questions/14227/…
    – H. Freeze
    Sep 29 '15 at 9:34
  • Thank you. Oh my, this looks much more complicated as what I was hoping for(hoped it would get cured by some checkbox in a wizard :D)
    – Javo
    Sep 29 '15 at 9:44
  • Haha, we could only hope, goodluck ;)
    – H. Freeze
    Sep 29 '15 at 9:46

The answer is Yes.

  • Create Live USB Storage
  • Boot it
  • Install to USB Storage#2
  • Boot from USB Storage#2

For safety, remove primary HDD before installing(for paranoiacs mainly)

  • Downfall My main motivation was to be able to have the media files on USB Storage#2 accessible in Windows and on my Smart TV. This is actually impossible to do properly(at least to my knowledge). I installed to a 'Removable drive', it's just a type defined by one Bit on the device. Some manufacturers provide a tool to switch this byte to 'Fixed drive'. I can't. Windows does not allow Removables to be multipartitioned.
    – Javo
    Oct 5 '15 at 8:23
  • Ive tried a [workaround][1] - Windows could play along if you set the Windows readable partition to be first in order. This actually worked, I could finally mount the partition in Windows. After soft restart I could boot from USB. But after turning off&on the PC, my BIOS refused to detect the storage. I had to boot to windows, reattach the storage and then it got detected by windows and after soft restart(restart executed in Windows/not HW reset - BIOS password is remembered) I could boot from USB storage again. [1]: rmprepusb.com/tutorials/multipartufd "workaround"
    – Javo
    Oct 5 '15 at 8:24
  • Installing to FAT32 is not possible for Ubuntu, nor Linux Mint, despite the misleading info I found. Mint has actually totally identical installation wizard as Ubuntu
    – Javo
    Oct 5 '15 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.