13

I am running Windows 7 host, Ubuntu guest inside of Virtualbox. I have installed guest additions, but when I go to display settings it stills says Unknown Display and doesn't let me add another monitor (added another monitor to this VM in virtualbox following instructions I found online). How do I get this to work? Have tried reinstalling guest additions but no success so far.

4
  • Have you tried to set up the monitor count to 2 for example in the settings of your virtual maschine (settings -> display -> monitor count)? Which version of virtualbox did you used?
    – Raistlin91
    Sep 29, 2015 at 10:26
  • Yes I have. 5.0.4
    – Andrew
    Sep 29, 2015 at 22:21
  • How much video memory is given, and is any acceleration enabled? google.co.uk/…
    – Tim
    Oct 7, 2015 at 10:07
  • 128 mb, no acceleration
    – Andrew
    Oct 9, 2015 at 1:04

6 Answers 6

9

It is very easy. Shutdown Virtual machine. Next go to virtual machine settings->Display. You should simply make Video RAM in virtual more than 64MB and make display count 2.

After this changes you should start VM and open Widows 7 change display resolution(Tool than configure display and its resolutions).

Here is video with WinXP but it would be very similar in Win7

UPD

Sorry. Here almost the same situation like by you: Host Ubuntu, Guest Ubuntu, VM Virtualbox. My install Sorry that it all in Russian(in English this settings have same places) but you can see that i have Guest Ubuntu with mirrored screens and Display settings. If i try to resize one of the screens other screen will be automatic resized.

4
  • The guest is Ubuntu...
    – Andrew
    Oct 7, 2015 at 15:53
  • I have updated my answer.
    – UNIm95
    Oct 7, 2015 at 20:42
  • I have all of the settings in VirtualBox the same, but when I go to display in system settings in Ubuntu guest I cannot add another monitor.
    – Andrew
    Oct 9, 2015 at 1:06
  • Can you make screen shot of Display settings in ubuntu?
    – UNIm95
    Oct 10, 2015 at 13:53
9

I found the solution for Ubuntu version 14.04 and above:-

  1. Set the number of displays to 2 or more from Virtualbox VM Settings(right-click on VM) -> Displays
  2. Then launch the VM and hit Ctrl(host-key) + C. This will show the Virtualbox menu at the top of the VM window
  3. Go to View -> Virtual Screen 2 -> Enable. This immediately enables the seconds screens

If you have more capable hardware enable more screens this way.

1
  • 1
    I've done the above. Virtual Screen 2 is already enabled - but under Display it doesn't show 2 monitors, it's exactly the same as with 1 monitors.
    – niico
    Aug 10, 2022 at 8:04
8

In my case, changing a VirtualBox graphics controller from "VMSVGA" to "VBoxVGA" helped. It is a bug in VirtualBox v6.0.14.

3
  • Thanks. This changed fixed it for me. Using the VMSVGA, I couldn't enable the second screen. On a windows host ubuntu guest. Switching to VBoxVGA fixed it.
    – KhoPhi
    Jan 8, 2020 at 15:06
  • In my case, I had to switch from "VboxVGA" to "VMSVGA" Nov 9, 2021 at 16:08
  • If I change to VBoxVGA it shows a black screen. If I use VMSVGA multiple monitors aren't even an option despite enabling in VirtualBox Manager and installing virtualbox-guest-x11
    – niico
    Aug 10, 2022 at 8:06
5
+100

Bottom edge - Virtual Screen 1 + 2

Menu reads = Use host screen X/+1

1
  • 4
    The fix I needed was to enable screen two in the bottom of the virtualbox window.
    – Andrew
    Oct 10, 2015 at 16:10
2

If it still won't work, try upping the video memory to as much as you can spare! The expressed limit was 18MB, i had mine sitting at 24MB, but it didn't work until i gave it 128MB.

VirtualBox 6.0.12, host Win10, guest Ubuntu 18.04.3

If it is still giving you problems leave the 3d Acceleration unchecked.

1

I have struggled a lot with this, unfortunately oracle has spent so much time on the inner workings of vbox and didn't do such a great job on the interface,

So, what would work after enabling the second monitor in settings, is you want to put your vm in floating window mode and in the lower bar that shows the stats of your running vm you want to click on the monitor icon and Enable the second monitor and then Congrats, you have two monitors.

Hope this helps

1
  • Fiddling around with the View menu is what got it for me.
    – Mike C
    Jul 18, 2022 at 15:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .