1

After some search, I didn't found exactly what my problem is, or at least I sould not relate it to any past questions I found.

Old setup

HDD with 2 partitions, grub booting ubuntu on one and win7 on the other. Everything went just fine.

New setup

One/two months ago I bought an SSD and I'm now writing this from its Win10. It has only this partition.

HDD got its Win7 partition formated but not the Ubuntu's. Problem is: when I try to boot (hotkey at the boot menu) from the HDD, it doesn't work anymore.

My understanding of the problem

I didn't wipe out the entire HDD contents, only the Win7 partition, so I thought even if Windows wouldn't boot anymore (obviously), Ubuntu would. Well and I don't think I got the knowledge to fix this up because I don't know if I can fix it as it is now or if I must wipe out the ubuntu partition and start over, or if I have to wipe grub from that drive (and I don't even know how to do this), lots of questions are popping!

What I want to learn

Okay now, the desired result is: Windows 10 booting from the SSD as it is now. Ubuntu booting from HDD partition #2 (if I recall the order number). HDD partition #1 serving as storage for Win10.

I don't care if boot process is either:

  • From the HDD, like "pc turns on, hdd starts grub, I choose, grub does his things" or
  • From boot hotkey, like "pc turns on, I press the boot device hotkey, choose drive, OS boots"

I just need it working as soon as possible. Thanks in advance.


Update: I managed to boot using the grub prompt, but I got to tty. Then as I found no problem there, I tried to reboot. When the Ubuntu logo (the loading screen) showed up was my last moment of happiness: it stopped there. Maybe something went wrong with video drivers, my video card or monitor?


fdisk -l output

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xf4ca1ca3

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 1495039999 747416576 7 HPFS/NTFS/exFAT
/dev/sda3 1495042046 1953523711 229240833 5 Extended
Partition 3 does not start on physical sector boundary.
/dev/sda5 1945526272 1953523711 3998720 82 Linux swap / Solaris
/dev/sda6 1495042048 1945526271 225242112 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6597ec03

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 1026047 512000 7 HPFS/NTFS/exFAT
/dev/sdb2 1026048 234438655 116706304 7 HPFS/NTFS/exFAT

Disk /dev/sdc: 8004 MB, 8004304896 bytes
255 heads, 63 sectors/track, 973 cylinders, total 15633408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x027e5a9a

Device Boot Start End Blocks Id System
/dev/sdc1 * 2048 15633407 7815680 c W95 FAT32 (LBA)

  • Start with a live usb, open a terminal, run 'sudo fdisk -l', and edit the post with the output. – kyodake Sep 28 '15 at 23:08
0

I would reinstall GRUB onto your HDD.

  1. Boot into liveUSB or liveCD
  2. Select "preview ubuntu" or find a way to get to the desktop w/o installing
  3. Open a terminal
  4. Run lsblk
  5. Using the output of lsblk, get the disk of the HDD (either /dev/sda or /dev/sdb probably).
  6. Run grub-install /dev/sdX where X is the letter seen previously
  7. Restart

If you still cannot boot into ubuntu, follow the first answer on this post.

After this, you can mess with the partitions using GParted. Search askUbuntu for more info on that.

  • grub-install returns "grub-install: error: failed to get canonical path of `/cow'." – Giuliano Sep 29 '15 at 21:40
  • What was the command you ran? Try following the answer on the post above, it will help more. – Zzzach... Sep 29 '15 at 23:21
  • Ah, see the update I wrote above in the question, before fdisk output – Giuliano Sep 29 '15 at 23:28
  • Sorry, my overlooking mistake. So you are able to get to grub? And Ubuntu seems to start to load, but fails? Can you get to a tty after rebooting? You also seem to have multiple NTFS partitions, do you have multiple copies of Windows? Also, which drive is your BIOS booting to? Where did you install grub? – Zzzach... Sep 29 '15 at 23:33
  • Yes I was able to get to grub, and by using the command prompt, to boot to tty. Ubuntu failed loading when I tried to reboot, it freezes at the loading screen. I had only one copy of Win7 installed but if I recall correctly, Windows needed one extra partition when it was installed (I think they are sda5 2 and 3). If I got it correctly, sda1 is where grub is and sda5 and 6 are my Ubuntu and its swap partition. My BIOS is currently booting from the SSD, not the same drive grub boots from. – Giuliano Sep 29 '15 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.