3

TL;DR: How do I get the 2560x1600 @60fps resolution from my Apple 30" Cinema Display?

Edited: Startech.com confirms the HDMI-to-DVI-D adaptor is dual channel. I don't have enough reputation to give more than 2 links in this, but the product number is HDDVIMF8IN and can be found on amazon.com.

I recently completed my first build, designed around my Apple 30" Cinema Display. This uses a DVI-D dual-channel cable, and has an optimal resolution of 2560x1600. Specs here. PartPicker Build Part list here.

I am using "trusty":

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:        14.04
Codename:       trusty

My intention was that the build be able to drive the screen at its optimal resolution of 2560x1600. I was disappointed that I misread the Motherboard specs, and the DVI-I port only drives 1920x1200 @ 60fps. Indeed, using the computer with the DVI-I port only gives 1280x800 resolution.

However, the HDMI ports do drive 2560x1600 @ 60fps. Subseqently, I purchased a Startech.com HDMI to DVI-D video adaptor, with the intention of plugging this into an HDMI port,so that I can get 2560x1600 resolution.

My problem: I can't get the screen, connected now with the HDMI-to-DVI cable, to give me any better (or, even different) than 1280x800 @60fps resolution. In this hardware configuration, the hardware doesn't recognize any but the 1280x800 default screen resolution. I've used cvt and xrandr to define 1920x1600 @45 fps resolution (to be safe) and 2560x1600 @ 60fps resolution, and all I get is the screen goes black.

Example of what I'm inputting:

rutledge@sekhmet:~$ cvt 1920 1200

\# 1920x1200 44.91 Hz (CVT) hsync: 55.42 kHz; pclk: 141.00 MHz
>Modeline "1920x1200_45.00"  141.00  1920 2032 2232 2544  1200 1203 1209 >1234 -hsync +vsync

xrandr --newmode "1920x1200" 141.00 1920 2032 2232 2544 1200 1203 1209 >1234 -Hsync +Vsync

>xrandr --addmode HDMI3  “1920x1200”

Output of xrandr is:

Screen 0: minimum 8 x 8, current 1280 x 800, maximum 32767 x 32767

HDMI1 disconnected (normal left inverted right x axis y axis)

HDMI2 disconnected (normal left inverted right x axis y axis)

HDMI3 connected primary 1280x800+0+0 (normal left inverted right x axis y >axis) 641mm x 401mm

   1280x800       59.9* 

   1920x1200      44.9  

VGA1 disconnected (normal left inverted right x axis y axis)

VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I can then set display resolution using "System Settings...Screen Display",and the screen goes black. Same thing if I do 1920x1200 @ 60fps or 2560x1600 @ 60 fps.

Finally, I should mention that I placed a .conf file into /usr/share/X11/xorg.conf.d which contains:

Section "Device"
        Identifier "Configured Video Device"
        Option "AllowDualLinkModes"
EndSection

So, does anyone have any insight as to how I can drive this screen at the desired resolution?

Possible sources of the problem which I can still identify:

  1. xrandr isn't working properly on my computer

  2. There are some default settings which should have been set, but aren't, and I have no idea what they are.

Thank you for your help!

  • Your motherboard seems to have a dual link DVI port. I'm not sure the startech.com adapter you bought supports dual link (you didn't provide a link to it). Also, are you certain that you have a cable which is dual link? – dobey Sep 28 '15 at 21:49
  • Since my posting, the cable tech support confirms that the cable is indeed dual link. So that cannot be the problem. Text above has been edited to reflect this. – Bob R. Sep 28 '15 at 21:58
  • And a link to the specific startech.com adapter you purchased? – dobey Sep 29 '15 at 13:06
  • Here is a link to the specific startech.com adapter I purchased - amazon.ca/gp/product/… – Bob R. Sep 29 '15 at 13:40
  • Are you certain the HDMI version of the adapter is 1.3 or newer? 1.0 only allows up to 1920x1200. – dobey Sep 29 '15 at 15:17
1

I don't believe it is your Trusty system, I believe it is the cable.

I bought this same adapter that you specified from startech.com, but for my Windows 10 PC to the 30" Apple cinema display. I am not able to get over 1280 resolution on this, either. I do suspect the cable, because I am able to use the 30" cinema display at full resolution when I use a dual DVI to Displayport cable. That cable has the extra USB cable attached needed for power. The Startech adaptor does not have that, so I tried just plugging in the monitor's USB cable, but it doesn't seem to work that way.

UPDATE 2019: I am now using Ubuntu 19.04 happily with the same setup; 1 connection uses the traditional DVI to miniDP cord from Apple, and the other monitor uses the same Bizlink/Dell dual DVI (plus a DP-to-Thunderbolt C adaptor since my Linux laptop does not have a DisplayPort). Note that I did have to tweak the Bios to get my System76/Clevo laptop to recognize the monitor on the Thunderbolt C though.

| improve this answer | |
0

I've had a similar problem. I wasn't able to get 2560x1600 from HP ZDisplay while connected with VGA, Mini DisplayPort/HDMI or Mini DisplayPort/HDMI + HDMI/HDMI cables. I've solved it by buying a Mini DisplayPort/DisplayPort cable with a declared support for 2560x1600 and using it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.