9

I have recently bought a new ASUS laptop which has Windows 10. Now I need to install Ubuntu 15.04 alongside Windows. I have done this before with my other laptops. However, now when i try to install Ubuntu, first during the installation it gives me a warning as;

Force UEFI Installation? This machines's firmware has started this installer in UEFI mode but it looks like there maybe existing operating systems already installed using BIOS compatibility mode, If you continue to install Debian in UEFI mode,it might be difficult to reboot into any BIOS-mode operating system.

Also note that I'm not getting the "Install alongside Windows" option. Instead, I see;

This computer currently has detected no operating systems.

Even though I have Windows 10 installed.

How can i install Ubuntu alongside Windows?

  • no i have the issue of UEFI and BIOS also. That thread does not refer to that. – user3832731 Sep 28 '15 at 18:19
  • If vendor installed any Windows 8 or later version it will be UEFI. Did you install (not upgrade) Windows 10 in BIOS mode? Post this: sudo parted -l If you force UEFI install it may convert drive to gpt and in effect erase MBR(msdos) and your Windows. Best to have Ubuntu in same boot mode UEFI or BIOS as Windows. If BIOS you need to boot Ubuntu installer in BIOS boot mode. Then with BIOS you have the 4 primary partition limit. Or your drive may have left over gpt data when you converted to BIOS. – oldfred Sep 28 '15 at 18:35
  • I haven't installed windows 10, they did. I bought from a local shop and they installed windows 10 in it. And now when i am trying to install ubuntu on it, it says " it looks like there maybe existing operating systems already installed using BIOS compatibility mode". So we can assume that the windows 10 was installed in BIOS compatibility mode. – user3832731 Sep 28 '15 at 18:41
  • How can i setup ubuntu in BIOS mode? – user3832731 Sep 28 '15 at 18:41
  • Are you talking about Ubuntu or about Debian? – Fabby Sep 30 '15 at 12:24
8

It's almost always best to boot all your OSes in the same mode (BIOS/CSM/legacy or EFI/UEFI). Most computers with Windows 8 and later pre-installed use EFI mode for this, but a small mom-and-pop computer store might still use BIOS mode. It sounds like this may be what you've got.

In this case, the question is how to get the Ubuntu installer to boot in BIOS mode rather than in EFI mode. Unfortunately, the answer varies from one system to another. Typically, you can access the computer's built-in boot manager by hitting Esc, Enter, or a function key as it starts up. With any luck, you'll be able to find this easily, and you'll see two options for your boot medium, one with the string "UEFI" and one without it. Select the option that lacks the "UEFI" string and the installer should boot in BIOS mode.

If you can find the boot manager but you don't see a non-UEFI boot option, or if that boot option gets you to the same complaint you're seeing, you can try a couple of things:

  • Create the boot medium in some other way. Some tools omit one boot loader or the other, so a BIOS-mode boot might fail and possibly fall back to an EFI-mode boot. Some tools (notably Rufus) offer options about what boot loaders to include. If you see such options, be sure to pick the ones for the most traditional BIOS-mode features, including the BIOS-mode boot loader and MBR partition table.
  • Use another USB flash drive. Some drives simply refuse to boot on some computers in BIOS mode. I don't know why this is, but I've seen it on some combinations. Switching from a USB flash drive to a DVD-R is also an option, if your computer has a DVD drive.

As to the lack of the "install alongside" option, this might be a consequence of booting in EFI mode -- this option is usually absent when booted in this way. The solution is to use the "Something Else" option. Note that if you boot in BIOS mode, you may see this option appear. OTOH, it could be you've got a damaged or flaky partition table, or one with leftover GPT data. Some such problems can be fixed with the fixparts tool, which is part of the gdisk package in Ubuntu. See this page of mine and the FixParts documentation for more on this subject. (Note that I'm the author of fixparts.)

Oh, one more thing: Be sure to disable the Windows "Fast Startup" feature, which turns shutdown operations into suspend-to-disk operations. This can cause disk corruption, and could be another reason you're not seeing the "install alongside" option.

  • I was stuck with this error for days while I tried installing and reinstalling Linux Mint. None of the solutions would work. Finally, I tried a different USB stick and it worked! I got the idea from this thread: ubuntuforums.org/showthread.php?t=2322918&page=2 – crypdick Dec 9 '16 at 4:54
  • Would there be a way to convert the windows installation to work with UEFI instead of BIOS? – daka Jan 21 '17 at 10:37
  • 1
    @sudoman, yes, that's possible, but it's a bit of a pain. See this blog post for details. As a general rule, once the first OS is installed on a computer, it's usually easiest to install all subsequent OSes in the same boot mode. Sometimes a switch is necessary, though; for instance, if you replace a sub-2TiB disk with a bigger one, which requires GPT and therefore EFI-mode booting (in Windows) to use the whole disk. – Rod Smith Jan 23 '17 at 17:35
  • @RodSmith dead link :( – Gus Oct 3 '17 at 4:05
0

The question you refer to says to answer with either OK or Cancel depending on if you want to proceed with the UEFI install, or switch to BIOS mode. Choose the one to switch to BIOS Mode ( I believe it was cancel ).

  • I have two options to this message: Go Back and Continue. Clicking on either does nothing. Cannot even close the popup window with it's own system close button on the title bar. – Simón Dec 24 '16 at 16:40
  • @Simón, that sounds like a different error that happens after grub fails to install, because you chose the wrong option at the earlier warning ( which incorrectly says Debian instead of Ubuntu ), and yes, that one often hangs the installer entirely and in any case. – psusi Jan 16 '17 at 3:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.