as you saw on the title, I got the "Failed to fetch... Hash Sum mismatch" Error. I have tried this method:

sudo rm -rf /var/lib/apt/lists/*
sudo apt-get update

But it didn't work. I still got the same error.

Err http ://vn.archive.ubuntu.com trusty-updates/universe amd64 Packages
Get:99 http ://vn.archive.ubuntu.com trusty-updates/universe amd64 Packages [1,789 B]
Get:100 http ://vn.archive.ubuntu.com trusty-updates/main i386 Packages [1,789 B]
Fetched 28.3 MB in 5min 15s (89.8 kB/s) 
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty/main/source/Sources  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/source/Sources  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-amd64/Packages  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/main/binary-i386/Packages  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-i386/Packages  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/main/i18n/Translation-en  Hash Sum mismatch
W: Failed to fetch http://vn.archive.ubuntu.com/ubuntu/dists/trusty-updates/universe/i18n/Translation-en  Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.

Please help! Thank you a lot!

  • Please open System Settings > Software & Updates and select another server than your current one in the Download from: dropdown menu. Then try again. Probably it's an issue with the archive server you use. – Byte Commander Sep 28 '15 at 9:16
  • In most cases this will be restored little later. – frlan Sep 28 '15 at 9:20
  • 1
    Use the main server and test it again. – A.B. Sep 28 '15 at 9:31
  • I think it's because of my internet connection. I stop trying and waited for some minute, then tried again and it worked :-? – Tai Christian Sep 30 '15 at 12:28

If deleting /var/lib/apt/lists/* does not work...
(esp. if you're behind a proxy), fix "Hash Sum Mismatch" like this:

Create file /etc/apt/apt.conf.d/99fixbadproxy
with this content

Acquire::http::Pipeline-Depth 0;
Acquire::http::No-Cache true;
Acquire::BrokenProxy    true;

See also here

  • sudo rm -rf /var/lib/apt/lists/* worked for me! – user3405291 Apr 4 '19 at 6:46

I used to get the same issue with jp.archive.ubuntu.com, usually it disappeared after a couple hours, so my guess is that it has something to do with your mirror's synchronisation with the master mirrors (i.e., you are fetching the package list while it is being synchronised). Switching to another mirror made such occurrences much less frequent for me (although they still do happen every now and then), so you may want to try that. (Here is the list of archive mirrors.)

Not the answer you're looking for? Browse other questions tagged or ask your own question.