3

I have a strange problem with my AltGr key.

My keyboard layout is set to "English (international AltGr dead keys)", but when I press AltGre I get a normal "e" instead of an "eacute" (é).

As workaround I added a second keyboard layout "English (Dvorak, international with dead keys)". After switching to the Dvorak layout and then immediately back to the AltGr layout, the combination AltGre gives an "eacute" (é).

In an other question someone mentioned running xev, so I did that too. Here is the output BEFORE the switch:

KeyPress event, serial 37, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 568919, (-1132,160), root:(130,212),
state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
XKeysymToKeycode returns keycode: 92
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 570395, (-1132,160), root:(130,212),
state 0x90, keycode 26 (keysym 0x65, e), same_screen YES,
XLookupString gives 1 bytes: (65) "e"
XmbLookupString gives 1 bytes: (65) "e"
XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 570530, (-1132,160), root:(130,212),
state 0x90, keycode 26 (keysym 0x65, e), same_screen YES,
XLookupString gives 1 bytes: (65) "e"
XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 571313, (-1132,160), root:(130,212),
state 0x90, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
XKeysymToKeycode returns keycode: 92
XLookupString gives 0 bytes: 
XFilterEvent returns: False

output AFTER the switch

KeyPress event, serial 49, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 662306, (62,149), root:(1324,201),
state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
XKeysymToKeycode returns keycode: 92
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyPress event, serial 49, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 662625, (62,149), root:(1324,201),
state 0x90, keycode 26 (keysym 0xe9, eacute), same_screen YES,
XLookupString gives 2 bytes: (c3 a9) "é"
XmbLookupString gives 2 bytes: (c3 a9) "é"
XFilterEvent returns: False

KeyRelease event, serial 49, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 662769, (62,149), root:(1324,201),
state 0x90, keycode 26 (keysym 0xe9, eacute), same_screen YES,
XLookupString gives 2 bytes: (c3 a9) "é"
XFilterEvent returns: False

KeyRelease event, serial 49, synthetic NO, window 0x5400001,
root 0x2c3, subw 0x0, time 664317, (62,149), root:(1324,201),
state 0x90, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
XKeysymToKeycode returns keycode: 92
XLookupString gives 0 bytes: 
XFilterEvent returns: False

I don't know if more info is needed to fix my problem, so please let me know if that's the case. And if you know how to fix it for me, please let me know.

Thanks, Matt

1

EDIT / reading again your question I understand that this one maybe is not answering you. I will let this here momentarily and see if it can be of general help.

Anyway, layout switching is so broken that it's not a surprise that it can do anything and its contrary... the second link here bite me a lot of time: even if you change layout, Ubuntu will often default to plain us unless you switch it back and forth, that may be your problem here.

I'll try here to give some ideas:

In "Internaltional Alt-Gr dead key" to have a "è" you have to press AltGr` and then e.

I don't know if the direct AltGre is defined to be anything --- I do not have the layout handy now.

You should be able to see the current layout in settings / region and language / Input Sources --- select the keyboard and press the small keyboard icon.

keyboard layout

On each key, the AltGr variants are the one on the right side. The keyboard shown is a personalized one, so it's different from the standard ones available.

You can find more info on my (mostly silent) blog here and here, and if you still have problem, check Alt-Gr key is not working in Ubuntu 13.10 and he post linked from there.

| improve this answer | |
  • Thanks for the reply Rmano. It didn't help fixing my problem, but it did help me to reread my question and hopefully make it more clear. – Mattijs Oct 3 '15 at 11:03
  • 1
    I suspect you are experiencing this bug --- the keyboard tend to go to "plain us" at login and then again sometime, and you need to switch back and forth to have your "Alt-Gr intl US" one. I suspect that the bug is still there because no one know why it happens. – Rmano Oct 3 '15 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.