16

I have an ext4 partition that I mount using the following fstab line

UUID=41dec246-654d-4e35-9d4e-68150e40c5b0 /mnt/Data     ext4    defaults,user      0      2

But then I realized that I can't execute from that partition. I checked my mount options and they were: rw,noexec,nosuid,nodev

So I changed the mount options to be more explicit as follows:

UUID=41dec246-654d-4e35-9d4e-68150e40c5b0 /mnt/Data     ext4    rw,suid,dev,exec,auto,user,async      0      2

But the partition still mounts with the same options (rw,noexec,nosuid,nodev).

I'm running Ubuntu 14.04 and I'm using UEFI booting. I'm also dual-booting with Windows 8.1

1
  • 3
    user implies noexec and order count so auto,user,exec if you need dev or suid or rw add them
    – Panther
    Sep 27, 2015 at 3:03

2 Answers 2

34

Change that line to

UUID=41dec246-654d-4e35-9d4e-68150e40c5b0 /mnt/Data     ext4    rw,suid,dev,auto,user,async,exec      0      2

The position of exec is important, since user also applies noexec. By putting exec after user, you ensure that exec is set. The most important options should be listed last.

1
  • 3
    This was the key to solve my problem. I had exec first and all my problems went away after moving it to the end.
    – endyourif
    May 13, 2018 at 17:59
0

Coming back from 22.04. This works for my laptop using Ubuntu 22.04 (LTS) and SSD with following commandline.

UUID=4B55B50364DA6FC6 /Data ntfs-3g defaults,user,exec,uid=1000,gid=1000,dmask=0777,fmask=0111,umask=0022 0 0

This works for me with the correct dmask and fmask.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .