At the present time, you might get this on auto-update, because the recent sbt packages are not authenticated.

enter image description here

2 Answers 2


To install the latest version of the sbt .deb package open the terminal and type:

sudo apt update
sudo apt install apt-transport-https curl gnupg -yqq
echo "deb https://repo.scala-sbt.org/scalasbt/debian all main" | sudo tee /etc/apt/sources.list.d/sbt.list
echo "deb https://repo.scala-sbt.org/scalasbt/debian /" | sudo tee /etc/apt/sources.list.d/sbt_old.list
curl -sL "https://keyserver.ubuntu.com/pks/lookup?op=get&search=0x2EE0EA64E40A89B84B2DF73499E82A75642AC823" | sudo -H gpg --no-default-keyring --keyring gnupg-ring:/etc/apt/trusted.gpg.d/scalasbt-release.gpg --import
sudo chmod 644 /etc/apt/trusted.gpg.d/scalasbt-release.gpg
sudo apt update
sudo apt install sbt

Once sbt is installed, you’ll be able to manage/update the package after you updated its package cache. You should also be able to see the added repository at the bottom of the list in Software & Updates -> Other Software.

sbt Reference Manual - Installing sbt on Linux


I manually downloaded & installed the latest version deb file from http://dl.bintray.com/sbt/debian/, and disabled that source url in ubuntu updates, as I am not aware how to tell it to suffice with an unautheticated source on each auto-update, nor do I think that would be a very good idea. Indeed that package updates /usr/share/sbt-launcher-packaging/bin/ where my previous version of sbt resided.

Some people suggested circumventing the need by using an alternative runner: https://github.com/paulp/sbt-extras, haven't tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.