4

So, I was trying to install the sync client for Mega (http://mega.nz) on my Ubuuntu 15.10 install. Yes, I know it's pre-release, but here is my question: When i install the .dep file, I get that

Errors were encountered while processing:
 megasync
dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libcrypto++9; however:
  Package libcrypto++9 is not installed.

When I then try to install libcrypto++9, I get the following error:

E: Package 'libcrypto++9' has no installation candidate

It then tells me that libcrypto++9v5 replaces it, but installing that doesn't satisfy MegaSync.

A quick Google search reveals that the v5 means "compiled using gcc5". Alas, the library is still the same. Why the new name, and how can I install my .deb file?

6

For Ubuntu 15.10 (All Versions):

Add this repository to your /etc/apt/sources.list (check here for other versions):

deb https://mega.nz/linux/MEGAsync/xUbuntu_15.10/ ./

Get/Add the key:

wget -O - https://mega.nz/linux/MEGAsync/xUbuntu_15.10/Release.key | sudo apt-key add -

Update: sudo apt-get update

Install MEGASync:

sudo apt-get install megasync

For Nautilus plugin:

sudo apt-get install nautilus-megasync

0

either download packages libcrypto++9 from here and install it using command :

sudo dpkg -i libcrypto++9_5.6.1-6+deb8u1build0.15.04.1_amd64.deb

or

it is in universal packages so add universal repository if not added and install using command

sudo apt-get install libcrypto++9

i have tested this in ubuntu 14.04 so megasync also depending on libc-ares2 packages download it from here and install it using command

sudo dpkg -i libc-ares2_1.10.0-2_amd64.deb 

or

it is available in main Ubuntu repository so add if not added and install using command

sudo apt-get install libc-ares2

then try to install megasync

sudo dpkg -i megasync-xUbuntu_15.04_amd64.deb
  • Sorry, I've been forced AFK. I have universal enabled. The problem only exists in ubuntu 15.10 because of the switch to gcc5 – bpou Sep 28 '15 at 13:23
  • @bpou did you get it fixed? I'm upgrading my 15.04 -> 15.10 and i'm having the same issue. It was there in 15.04 to, but i can't remember how i fixed it. – mote Oct 27 '15 at 9:46
  • I manually edited the dependencies of the deb file. HOWTO here: ubuntuforums.org/showthread.php?t=110458 – LinuxStudent Nov 27 '15 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.