5

I'm running Ubuntu 14.04 on my laptop. The last time I used it (several weeks ago) the wireless was working fine. I turned it on today and no networks will show up, with the network menu saying "No network devices available."

I've disabled and enabled networking, and restarted the computer several times now. I've also tried pressing the key combination to turn the wireless adapter off and back on (FN+F2), but that didn't seem to do anything.

Most other posts I've seen while searching for solutions are cases of people having problems when they initially install the OS and not having drivers. It worked before for me so I know I have working drivers installed. I haven't messed with drivers or updated the system, or done anything with it at all since I last used it.

I've seen people on other posts request running iwconfig and ifconfig for more information, results of those below:

iwconfig:

no wireless extensions.

ifconfig:

Link encap:Local Loopback
inet addr:127.0.0.1  Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING  MTU:65536  Metric:1
RX packets:161 errors:0 dropped:0 overruns:0 frame:0
TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11409 (11.4 KB)  TX bytes:11409 (11.4 KB)

Edit: Requested output of lspci -knn | grep Net -A2

02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
        Subsystem: Dell Device [1028:0208]

Edit 2: Requested output of dpkg -l | grep linux-image

ii  linux-image-3.13.0-32-generic        3.13.0-32.57  amd64  Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-3.13.0-34-generic        3.13.0-34.60  amd64  Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-3.13.0-59-generic        3.13.0-59.98  amd64  Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-extra-3.13.0-32-generic  3.13.0-32.57  amd64  Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-extra-3.13.0-34-generic  3.13.0-34.60  amd64  Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-generic                  3.13.0.34.40  amd64  Generic Linux kernel image
7
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Sep 26 '15 at 16:57
  • Added to original post. – Eli Silverhand Sep 26 '15 at 17:32
  • Please also add output of dpkg -l | grep linux-image – Pilot6 Sep 26 '15 at 18:10
  • Edit: Nevermind my original comment here if you saw it, adding to original post now. – Eli Silverhand Sep 26 '15 at 18:14
  • Please post the whole output of the command to your question. It looks like you do not have the correct linux-image-extra. Can you connect to internet by wire? – Pilot6 Sep 26 '15 at 18:17
5

You do not have linux-image-extra for the running kernel 3.13.0-59. The kernel module ath9k is not installed. That is probably because the upgrade had been interrupted.

You need to connect to the internet by wire and run

sudo apt-get update
sudo apt-get dist-upgrade

If that does not install the extras, you can manually install them by

sudo apt-get install linux-image-extra-3.13.0-59-generic

but this means that some dependencies are not correct.

If you can't connect by wire, then boot with one of the previous kernels using grub menu. The wifi should work.

Then run the same commands.

Another option is to switch to 3.19 kernel by running

sudo apt-get install linux-generic-lts-vivid
7
  • Don't have an ethernet port on this PC so I can't use a wired connection, but I ran the 3.13.0-34 kernel, wireless works fine on that. Ran the update and upgrade commands (took a bit, thus the late reply). Rebooted once those were finished and wireless is still showing "No network devices available" on the latest kernel. – Eli Silverhand Sep 26 '15 at 18:57
  • That's weird. But you can run sudo apt-get install linux-image-extra-3.13.0-59-generic. That must be a bug with dependencies.. – Pilot6 Sep 26 '15 at 19:00
  • Just to be clear, I should boot into 3.13.0-34 again and run that, correct? – Eli Silverhand Sep 26 '15 at 19:03
  • Correct. Or the other command I added to the answer. – Pilot6 Sep 26 '15 at 19:04
  • Tried the answer you posted in the comments here, rebooted, and wireless is working fine on that now.Thanks so much for your help with this! – Eli Silverhand Sep 26 '15 at 19:11
0

Although, this is not an answer-answer to this problem, but one of the quicker one-time solution. If you experiencing this issue, and you want wi-fi rather sooner then later, then reboot Ubuntu, select "Advanced options for Ubuntu" on startup, and when the list appears select first next version of kernel other then the very top once (which is the one you use when you normally boot to Ubuntu). Also, when saying "First next" by that I mean skip any options that has recovery mode label added.

The kernel might have been corrupted, so if you want a quick solution and need wi-fi immediately, switch to using some of the older versions of the kernel, and it should work (worked for me).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.