2

I am having trouble installing wine in Ubuntu 14.04, 64-bit. Here is what i have tried.

1) Terminal

sudo add-apt-repository ppa:ubuntu-wine/ppa -y
sudo apt-get update  
sudo apt-get install wine

as given here

This is giving the following error.

$ sudo apt-get install wine
[sudo] password for sanchit: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:
  wine : Depends: wine1.6 but it is not going to be installed or
                  wine1.7 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

These questions have been asked a lot of times.

  1. This one suggests sudo dpkg --add-architecture i386. But it was not useful. enter image description here

  2. This lists generic solutions. Did

     sudo apt-get clean
     sudo apt-get -f install
     sudo dpkg --configure -a
     sudo apt-get -u dist-upgrade
    
  3. This one says sudo apt-get install wine1.7. Tried did this too, but it isn't working.

    $ sudo apt-get update 
    $ sudo apt-get install wine1.7
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
    wine1.7 : Depends: wine1.7-i386 (= 1:1.7.50-0ubuntu1)
    E: Unable to correct problems, you have held broken packages.
    

Ubuntu Software Centre:

enter image description here

  • please edit question and add output of sudo dpkg --print-architecture and sudo dpkg --print-foreign-architectures – Ravan Sep 26 '15 at 8:28
  • have you tried wine installation from Software centre ? – Ravan Sep 26 '15 at 8:39
0

I had the same problem on one Ubuntu 14.04 64-bit installation, but not on the other. Actually, there were two problems:

Removal of nvidia-libopencl1 packages

Synaptic wants to remove two nvidia packages when I select wine; this looked strange to me, and I found nvidia-libopencl1-331 has to be removed before installing WINE / referring to https://bugs.launchpad.net/ubuntu/+source/wine1.6/+bug/1320217

So, my first step was to remove the packages:

,----[ Synaptic action ]----
| Completely removed the following packages:
| nvidia-libopencl1-352
|
| Removed the following packages:
| nvidia-libopencl1-346
|
| Installed the following packages:
| ocl-icd-libopencl1 (2.1.3-4)
`----

Use aptitude's advance dependency resolution

This was recommended in https://ubuntuforums.org/showthread.php?t=2188107&page=2; I don't understand all the magic, but apparently you can convince aptitude to find a solution that only required the downgrade of a single package (libltdl7 [2.4.2-1.11ubuntu1~trusty1 (now) -> 2.4.2-1.7ubuntu1 (trusty)] in my case), and then wine finally installs just fine!

$ sudo apt-get install aptitude
$ sudo aptitude --full-resolver -f install wine
The following NEW packages will be installed:
  binfmt-support{a} fonts-horai-umefont{a} fonts-unfonts-core{a}
  fonts-wqy-microhei{a} gnome-exe-thumbnailer{a} icoutils{a}
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a}
  libavahi-client3:i386{a} libavahi-common-data:i386{a}
  libavahi-common3:i386{a} libcapi20-3{a} libcapi20-3:i386{a}
  libcgmanager0:i386{a} libcomerr2:i386{a} libcups2:i386{a}
  libdb5.3:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a}
  libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a}
  libexif12:i386{a} libgcrypt11:i386{a} libgd3:i386{a} libgif4:i386{a}
  libgl1-mesa-dri-lts-vivid:i386{a} libgl1-mesa-glx-lts-vivid:i386{a}
  libglapi-mesa-lts-vivid:i386{a} libglu1-mesa:i386{a} libgnutls26:i386{a}
  libgpg-error0:i386{a} libgphoto2-6:i386{a} libgphoto2-port10:i386{a}
  libgpm2:i386{a} libgssapi-krb5-2:i386{a} libgssapi3-heimdal:i386{a}
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a}
  libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a}
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a}
  libieee1284-3:i386{a} libjack-jackd2-0:i386{a} libjbig0:i386{a}
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a}
  libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a}
  libkrb5support0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a}
  libllvm3.6:i386{a} libltdl7:i386{ab} liblzma5:i386{a} libmpg123-0:i386{a}
  libncurses5:i386{a} libnih-dbus1:i386{a} libnih1:i386{a}
  libnss-winbind{a} libodbc1{a} libopenal1:i386{a} liborc-0.4-0:i386{a}
  libosmesa6{a} libosmesa6:i386{a} libp11-kit-gnome-keyring:i386{a}
  libp11-kit0:i386{a} libpam-winbind{a} libpciaccess0:i386{a}
  libroken18-heimdal:i386{a} libsamplerate0:i386{a} libsane:i386{a}
  libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a}
  libspeexdsp1:i386{a} libsqlite3-0:i386{a} libssl1.0.0:i386{a}
  libtasn1-6:i386{a} libtiff5:i386{a} libtinfo5:i386{a}
  libtxc-dxtn-s2tc0:i386{a} libudev1:i386{a} libusb-1.0-0:i386{a}
  libv4l-0:i386{a} libv4lconvert0:i386{a} libvpx1:i386{a}
  libwind0-heimdal:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a}
  libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a}
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a}
  libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a}
  libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a}
  libxt6:i386{a} libxxf86vm1:i386{a} ocl-icd-libopencl1:i386{a} odbcinst{a}
  odbcinst1debian2{a} p11-kit-modules:i386{a} p7zip{a} ttf-wqy-microhei{a}
  unixodbc{a} winbind{a} wine wine-gecko2.21{a} wine-gecko2.21:i386{a}
  wine-mono0.0.8{a} wine1.6{a} wine1.6-amd64{a} wine1.6-i386:i386{a}
  winetricks{a}
0 packages upgraded, 126 newly installed, 0 to remove and 0 not upgraded.
Need to get 172 MB of archives. After unpacking 570 MB will be used.
The following packages have unmet dependencies:
libltdl7 : Breaks: libltdl7:i386 (!= 2.4.2-1.11ubuntu1~trusty1) but 2.4.2-1.7ubuntu1 is to be installed.
libltdl7:i386 : Breaks: libltdl7 (!= 2.4.2-1.7ubuntu1) but 2.4.2-1.11ubuntu1~trusty1 is installed.
The following actions will resolve these dependencies:

    Keep the following packages at their current version:
1)     libgphoto2-6:i386 [Not Installed]
2)     libgphoto2-port10:i386 [Not Installed]
3)     libltdl7:i386 [Not Installed]
4)     libsane:i386 [Not Installed]
5)     wine [Not Installed]
6)     wine1.6 [Not Installed]
7)     wine1.6-amd64 [Not Installed]
8)     wine1.6-i386:i386 [Not Installed]

    Leave the following dependencies unresolved:
9)     winetricks recommends wine


Accept this solution? [Y/n/q/?] 6
Action "6": Removing wine1.6

Package: wine1.6
State: not installed; will be installed
Multi-Arch: allowed
Version: 1:1.6.2-0ubuntu4
Priority: optional
Section: universe/otherosfs
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Architecture: amd64
Uncompressed Size: 3,103 k
Depends: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.17), wine1.6-amd64 (=
        1:1.6.2-0ubuntu4), binfmt-support (>= 1.1.2), procps, wine1.6-i386 (=
        1:1.6.2-0ubuntu4)
PreDepends: dpkg (>= 1.15.7.2~)
Recommends: cups-bsd, gnome-exe-thumbnailer | kde-runtime, fonts-droid,
            fonts-liberation, ttf-mscorefonts-installer, fonts-horai-umefont,
            fonts-unfonts-core, ttf-wqy-microhei, winbind, winetricks, xdg-utils
Suggests: dosbox:any
Conflicts: wine1.0, wine1.0, wine1.2, wine1.2, wine1.3, wine1.3, wine1.6
Replaces: wine, wine, wine1.0, wine1.0, wine1.2, wine1.2, wine1.3, wine1.3,
          wine1.4, wine1.4, wine1.5, wine1.5
Provides: wine, wine1.6:any
Description: Microsoft Windows Compatibility Layer (Binary Emulator and Library)
Wine is a compatibility layer for running Windows applications on Linux.
Applications are run at full speed without the need of cpu emulation. Wine does
not require Microsoft Windows, however it can use native system dll files in
place of its own if they are available.

This package includes a program loader for running unmodified Windows
executables as well as the Wine project's free version of the Windows API for
running programs ported from Windows.
Homepage: http://www.winehq.org/


This action was selected because wine1.6 depends upon wine1.6-i386 (=
1:1.6.2-0ubuntu4).

Enter "r 6" to prevent this action from appearing in new solutions.
Enter "a 6" to require that new solutions include this action if possible.

Accept this solution? [Y/n/q/?] r 6
Rejecting the removal of wine1.6
The following actions will resolve these dependencies:

    Keep the following packages at their current version:
1)     libgphoto2-6:i386 [Not Installed]
2)     libgphoto2-port10:i386 [Not Installed]
3)     libltdl7:i386 [Not Installed]
4)     libsane:i386 [Not Installed]
5)     wine [Not Installed]
6) R   wine1.6 [Not Installed]
7)     wine1.6-amd64 [Not Installed]
8)     wine1.6-i386:i386 [Not Installed]

    Leave the following dependencies unresolved:
9)     winetricks recommends wine


Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

    Downgrade the following packages:
1)     libltdl7 [2.4.2-1.11ubuntu1~trusty1 (now) -> 2.4.2-1.7ubuntu1 (trusty)]



Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
  libltdl7
The following NEW packages will be installed:
  binfmt-support{a} fonts-horai-umefont{a} fonts-unfonts-core{a}
  fonts-wqy-microhei{a} gnome-exe-thumbnailer{a} icoutils{a}
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a}
  libavahi-client3:i386{a} libavahi-common-data:i386{a}
  libavahi-common3:i386{a} libcapi20-3{a} libcapi20-3:i386{a}
  libcgmanager0:i386{a} libcomerr2:i386{a} libcups2:i386{a}
  libdb5.3:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a}
  libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a}
  libexif12:i386{a} libgcrypt11:i386{a} libgd3:i386{a} libgif4:i386{a}
  libgl1-mesa-dri-lts-vivid:i386{a} libgl1-mesa-glx-lts-vivid:i386{a}
  libglapi-mesa-lts-vivid:i386{a} libglu1-mesa:i386{a} libgnutls26:i386{a}
  libgpg-error0:i386{a} libgphoto2-6:i386{a} libgphoto2-port10:i386{a}
  libgpm2:i386{a} libgssapi-krb5-2:i386{a} libgssapi3-heimdal:i386{a}
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a}
  libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a}
  libheimntlm0-heimdal:i386{a} libhx509-5-heimdal:i386{a}
  libieee1284-3:i386{a} libjack-jackd2-0:i386{a} libjbig0:i386{a}
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a}
  libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a}
  libkrb5support0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a}
  libllvm3.6:i386{a} libltdl7:i386{a} liblzma5:i386{a} libmpg123-0:i386{a}
  libncurses5:i386{a} libnih-dbus1:i386{a} libnih1:i386{a}
  libnss-winbind{a} libodbc1{a} libopenal1:i386{a} liborc-0.4-0:i386{a}
  libosmesa6{a} libosmesa6:i386{a} libp11-kit-gnome-keyring:i386{a}
  libp11-kit0:i386{a} libpam-winbind{a} libpciaccess0:i386{a}
  libroken18-heimdal:i386{a} libsamplerate0:i386{a} libsane:i386{a}
  libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a}
  libspeexdsp1:i386{a} libsqlite3-0:i386{a} libssl1.0.0:i386{a}
  libtasn1-6:i386{a} libtiff5:i386{a} libtinfo5:i386{a}
  libtxc-dxtn-s2tc0:i386{a} libudev1:i386{a} libusb-1.0-0:i386{a}
  libv4l-0:i386{a} libv4lconvert0:i386{a} libvpx1:i386{a}
  libwind0-heimdal:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a}
  libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a}
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a}
  libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a}
  libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a}
  libxt6:i386{a} libxxf86vm1:i386{a} ocl-icd-libopencl1:i386{a} odbcinst{a}
  odbcinst1debian2{a} p11-kit-modules:i386{a} p7zip{a} ttf-wqy-microhei{a}
  unixodbc{a} winbind{a} wine wine-gecko2.21{a} wine-gecko2.21:i386{a}
  wine-mono0.0.8{a} wine1.6{a} wine1.6-amd64{a} wine1.6-i386:i386{a}
  winetricks{a}
0 packages upgraded, 126 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 172 MB of archives. After unpacking 570 MB will be used.

Other things I had tried in vain:

Use a newer (wine 1.8) version from the PPA:

$ sudo -E add-apt-repository ppa:ubuntu-wine/ppa
$ sudo apt-get update

→ Didn't work, remove repository in Synaptic again.


Enabling 32-bit x86 support:

$ sudo dpkg --add-architecture i386; sudo apt-get update

$ sudo apt-get remove --purge wine

→ Doesn't help, as it isn't installed yet.


$ sudo apt-get autoremove

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.