2

So far, here are the steps I've taken:

In a fully-updated 14.04 (as super user)

  1. sudo apt-get install xrdp

  2. sudo apt-get update

  3. sudo apt-get install xfce4

  4. echo xfce4-session >~/.xsession

  5. sudo service xrdp restart

In Windows 7

  1. Open RDP

  2. Enter 14.04's IP

  3. Enter credentials

I then get the following two screens:

Connection Log:

enter image description here

Gray Screen:

enter image description here

Then everything crashes and I go back to the RDP connection manager in Windows.

I've also created a new, separate account in 14.04 that is only used for the RDP session, and that didn't seem to change any behavior(s).

Any ideas?

0

This might be an old question but some people might still be interested in having a solution for that. Based on your description, the setup seems correct.

  • you have installed standard xrdp package sudo apt-get install xrdp
  • you have installed an alternate desktop (xfce)
  • you have created the .xsession file with the correct information

Generally speaking, grey screen is because something is wrong with the .xsession file or the user that login

My guess is that you have done the configuration while logged in with userA but when trying to login via xrdp you are using userB.

The .xsession file is per user based. If you have multiple users, you have to create for each user the .xsession file with the proper information or you can automate this (for automating check info here )

So, you have two options :

Option 1 - login locally on ubuntu (no xrdp) with the userB and issue the command

- echo xfce4-session >~/.xsession

Option 2 - have the system create the .xsession file automatically for each user (again full info can be found at here

  • Edit the startwm.sh file -> sudo gedit /etc/xrdp/startwm.sh
  • Append in this file (just after the word "fi") the following line

  • echo xfce4-session >~/.xsession

If this is still not fixing your issue, you can have a look in the log files. check for the file ~/.xsession-errors (for the user having the grey screen)

Please provide feedback if this is working for you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.