6

A specific application I use doesn't play well with network-manager. I would like to purge network-manager and configure my connections manually.

I have a dhcp connection to the network, and a static ip connection to an ethernet device.

How should I configure my ubuntu?

I tried setting /etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth3
iface eth3 inet static
address 192.168.155.130
netmask 255.255.0.0
gateway 192.168.155.1

But that didn't work at all. Are there other things I need to consider?

1
  • 1
    Can you qualify "didn't work at all"? What do you expect, and what actually happens? What routing are you trying to achieve? – steeldriver Sep 26 '15 at 0:28
3

You need to do 2 things:

  1. Remove network manager:

sudo apt-get purge network-manager

Alternatively you can disable it without uninstalling:

sudo stop network-manager echo "manual" | sudo tee /etc/init/network-manager.override

  1. Configure your network interfaces with ifup:

sudo ifup eth0 sudo ifup eth3

The interfaces marked with auto in /etc/network/interfaces are brought up automatically at boot. So actually this step is only needed to bring them up manually.

To bring an interface down, use ifdown.

--

References:

3
  • There is no need to uninstall or stop NM. It ignores all interfaces listed in /etc/network/interfaces. – Pilot6 Sep 26 '15 at 14:01
  • From what I remember I don't think it does it on 12.04 unless you configure it specifically. – o9000 Sep 26 '15 at 18:36
  • ifup and ifdown are no longer installed in Ubuntu. I can't add them because I can't bring up the network interface. – tim11g Jun 4 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.