0

Seattle University doesn't provide any support for linux, although my Android phone appears to work fine. I am able to connect to both the encrypted and unencrypted wireless networks, as well as wired, and I am assigned an IP address. I appear to be able to ping external ips like Google's DNS at 8.8.8.8, and ip addresses that I know are valid but unused return no ping (all good so far). I can also curl external IPs. However, when I try to resolve a DNS host, it doesn't work, regardless of wired/wireless. I tried setting my DNS in network manager to use Google's DNS, but that didn't seem to change anything. I have verified with IT that my settings appear correct, based on their experience configuring Windows, OSX, and Android.

How would I troubleshoot or work around this issue? The IT guy didn't know that Ubuntu and Android were Linux-based, and his only suggestion was "well, it should work, but if it doesn't install Windows."

EDIT: When I run dig it looks like this: $ dig google.com @8.8.8.8 ; <<>> DiG 9.9.5-3ubuntu0.4-Ubuntu <<>> google.com @8.8.8.8 ;; global options: +cmd ;; connection timed out; no servers could be reached

My resolv.conf looks fine, it picks up Google's DNS when I'm set to Google's DNS and picks up what look like the University's DNS servers otherwise.

1

Normally to troubleshoot DNS problems I do the following:

  • Check if a public DNS server (such as Google's 8.8.8.8) is reachable:

ping 8.8.8.8

(IIUC this works for you)

  • Try to resolve a name to see if DNS queries can reach it (the university's firewall might block them or interfere in some other ways):

dig google.com @8.8.8.8

or

host google.com 8.8.8.8

If that doesn't work, then you cannot use 8.8.8.8 as a DNS server.

  • Check if the system is indeed configured to resolve names through 8.8.8.8 (since you said you configured it statically in Network Manager):

cat /etc/resolv.conf

You should see something like:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 8.8.8.8

If that is not the case, I would check the NetworkManager config again.

For a quick and dirty fix you can also edit that file, but keep in mind that NetworkManager or other programs will overwrite it the next time you reconnect (which might be sooner than you think if wifi drops for instance). So it is best to configure it in NetworkManager.

  • Check if you can indeed resolve the names you need with that DNS server.

Usually using external DNS servers is OK, except when there are machines on your university's campus that use private IP addresses. Those ones cannot be resolved through external DNS servers. So you actually need to use your university's DNS server.

In this case you could just leave the DNS servers as not configured in NetworkManager and it should pick them up from DHCP. If that doesn't happen, you could either troubleshoot it or just copy the DNS setting from another machine that works and set it statically in NetworkManager.

  • dig returns: $ dig google.com @8.8.8.8 ; <<>> DiG 9.9.5-3ubuntu0.4-Ubuntu <<>> google.com @8.8.8.8 ;; global options: +cmd ;; connection timed out; no servers could be reached My /etc/resolv.conf looks fine; when I'm set to use Google's DNS it is set to 8.8.8.8, when I set DNS to automatic it picks up what I assume are the University's DNS servers. Is it time to break out wireshark or is there something else I can check? – Strawberry Sep 28 '15 at 20:34
  • Looks like DNS traffic to/from 8.8.8.8 is blocked. Can you run dig again replacing 8.8.8.8 with your university DNS server? I would also look at the local firewall rules (iptables -L -n -v --line-numbers) just to make sure that's not the problem. – o9000 Sep 28 '15 at 21:59
  • dig with the university's DNS IP doesn't work. I should also note that I had to disable dnsmsq in order for the university's DNS to show up in my resolv.conf. Prior to that it was 127.0.1.1. I'll report back with iptables once I test it. Any other ideas would be much appreciated. – Strawberry Oct 2 '15 at 16:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.