Just upgraded from 11.04 to 11.10. Power management worked fine in natty, now on lid close it just blanks screen but does not put the computer to sleep. Interestingly, sometimes even does not blank screen at all, but when the lid is reopened, does it for a second or two, and then back to life. Changing options from system settings and gconf-edit doesn't help. Anyone has a similar problem?

I'm on Toshiba Satellite E105, Intel Core2 Duo P8400, 4GB RAM etc., don't even know why I'm writing that :)


I have a doubt: if you explicitly click in the 'suspend' option in the system button, the laptop suspends correctly?

If the laptop suspends correctly, then this is just a configuration problem... In this case, you can install the Gnome Tweak Tool:

sudo apt-get install gnome-tweak-tool

After running the tweak tool, you should select the "Shell" option and change the two options "Laptop lid close action on battery" and "Laptop lid close action on AC" to "suspend".

I hope this can help you.



| improve this answer | |
  • Tried this, didn't work. You can do the same thing by going into the System Settings and selecting the Power icon. From within the Power dialog you can specify what to do when on battery & power, i.e. select suspend. – slm Mar 21 '12 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.