0

I have selected white-on-black color scheme for Gnome-Terminal. But it keeps using green to display executable files and uses different colored background to display some directories. How can I enforce strict "white-on-black" for all items on the screen?

1
  • Updated my answer – A.B. Sep 26 '15 at 9:11
2

To temporary disable colors for ls use

\ls

or use

dir

For a permanent change you have to delete the alias for ls. In my case the alias is defined as

% alias ls
ls='ls --color=tty'

Therefore overwrite the alias in e.g. your .bashrc

alias ls='ls --color=never'

The "sneaky way is ;)

  1. Open gnome-terminal

  2. Edit your profile settings via

    Edit > Profile Preferences

  3. Open the tab Colors

  4. Customize your colors

    enter image description here

5
  • That's sneaky. :D – muru Sep 25 '15 at 17:08
  • @muru: why "sneaky"? – Fabby Sep 25 '15 at 23:36
  • @Fabby if my ls isn't colouring output, I'd be looking at options for ls, not the terminal palette. – muru Sep 26 '15 at 4:14
  • @muru omg he means ls o_O – A.B. Sep 26 '15 at 6:30
  • @muru: :D :D :D I didn't spot that either! Good one! – Fabby Sep 26 '15 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.