1

At work I have an ubuntu desktop behind a proxy. I configured my proxy as follows: Under Settings > Network > Network proxy : Method set to "automatic", set a URL and applied system wide.

This enabled access to the internet (eg firefox), except for apt-get. To get apt-get working, I followed these instructions, specifically under "Setting up apt-get to use a http-proxy > APT configuration file method". With these settings I can install packages (eg thunderbird), but I have a problem when I add a new repository:

W: GPG error: http://ppa.launchpad.net vivid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 737F9811F93FF666

I'm assuming this has something to do with the proxy, but I can't seem to fix it with any method/tip I have found online so far. For example, adding the proxy settings as environment variables (export https_proxy=...) and then using sudo -E did not help.

1
sudo -i
export http_proxy=http://foo.bar.com:1234 # change this to the correct values
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 737F9811F93FF666
exit

Hope that works for you. If it doesn't then maybe post the error you get

| improve this answer | |
  • It worked, thanks :) but does this mean I will have to explicitly import every key for a new repo like that? Or is there a global configuration change I can make to solve this problem once and for all? – PieterV Sep 28 '15 at 7:09
  • you can use apt-add-repository to automate getting the key for PPAs. – ssta Sep 28 '15 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.