8

i have a usb wifi adapter Tp-Link model: wn725n it works very well on windows but i can't find any drivers for linux/ubuntu i tried everything online but nothing work so far

i'm using

Ubuntu 14.04.3 LTS

3.19.0-28-generic

laptop: hp probook 4540s

can you please help me install this adapter?

14

I found the solution. I installed the driver for the usb wifi adapter successfully using the following:

sudo apt-get update
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get update
sudo apt-get install build-essential
sudo apt-get install git
git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make all
sudo make install
sudo modprobe 8188eu.ko

and then I used the following command:

sudo lshw -C network

to get the internal wifi driver file name and then add it to blacklist

sudo -H gedit /etc/modprobe.d/blacklist

and add the following line to the end of the file:

blacklist xxxxx

where xxxx is the internal wifi driver file name.

Restart and Ubuntu should now work with the usb adapter.

Note: if your internal wifi is fine then you don't need to blacklist it, i only did that because it was tuened off by hardware switch and doesn't want to turn on again and it turns off the usb wifi as well so i had to blacklist it.

| improve this answer | |
  • good that you posted it. – Kazim Zaidi Feb 24 '16 at 3:44
  • What was the internal wifi driver name? – JohnAllen Apr 15 '16 at 22:25
  • in Alaa's solution from beginning, between lines git clone https://github.com/lwfinger/rtl8188eu and make all should be added: cd rtl8188eu – NapierDeltic Jan 1 '17 at 12:17
  • it was /etc/modprobe.d/blacklist.conf in my case (editing /etc/modprobe.d/blacklist didn't affect nothing) – nazar kuliyev Apr 26 '17 at 9:09
  • Great answer! I didn't had an internal wifi driver. So using sudo lshw -C network displayed me only my ethernet drivers, no wifi driver - so i skipped the last few steps and it worked – Tushar Goswami Sep 5 '17 at 5:20
5

This device worked out of the box for me with Xubuntu 16.04.01 (32-bit). No need to manually install any drivers or even do anything at all. If it doesn't work immediately, do a reboot. It works for me without any tinkering or installation of anything at all.

Please note that I had the dongle plugged in even as I booted from the live CD and installed Xubuntu.

| improve this answer | |
5

I was able to install without installing the rtl8188eu driver mentioned in other answer. My installation worked pretty fine by downloading the TL-WN725N driver from the official TPLink website and firing the following commands as instructed in their installation manual :

sudo make
sudo make install

I ran the above commands by cd'ing into the Driver folder downloaded in driver's archive file

EDIT: in newer kernel versions this solution does not work

| improve this answer | |
4

Actually there are 2 different revision of this tl-wn725n wifi adapter, the v1 and the v2 which have different chipsets.

How to recognize them?

The tp-link website say that is possible to recognize them by the FCCID (labeled on the adapter).

If your FCCID terminates with v2 then is the second revision, which use the RTL8188EUS Realtek chipset.

Otherwise if your FCCID terminates with v1 (or you can't find a hardware version) it is the first revision, based on the Realtek RTL8188CUS chipset.

Where do i find the driver?

For the v2 version on the tp-link website : here

For the v1 version here (from realtek) , or here

More info:

https://wikidevi.com/wiki/TP-LINK_TL-WN725N_v1

| improve this answer | |
2

I connected my HP laptop with internet using USB tethering to my mobile and Following are the commands that worked for me

sudo apt-get install linux-headers-generic build-essential
git clone https://github.com/lwfinger/rtl8188eu.git
cd rtl8188eu/
make
sudo make install
sudo modprobe 8188eu
sudo reboot 

I'm using Ubuntu 16.04.4 LTS 64-bit and TP-Link 150Mbps Wireless N Nano USB Adapter TL-WN725N

| improve this answer | |
  • I can confirm this worked for me on Debian 10 buster to get it working. I did not have to reboot, but simply unplug and plug back in the usb adapter and it started working right away and I connected to wifi network. – jamescampbell Jun 27 at 16:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.