0

I've just installed Ubuntu without any errors, but it won't boot. It skips past HDD in the boot order and goes to the next one.

I tried to do boot-repair as it is explained here: Ubuntu doesn't boot after installation, but it doesn't work.

I've run multiple linux installations on my computer before and this has only become a problem with recent linux versions.

These are the boot-repair logs: http://paste.ubuntu.com/12543053/ http://paste.ubuntu.com/12543267/

0

I guess you've managed to find a way round this in the 9 months you have been waiting for an answer but it looks similar to a dual boot problem I had with a uefi system.

The boot process is looking for a bootloader in the MBR but the boot files loaded all look to be .efi and these need to operate in a GPT formatted disk.

I think the problem might well have started in your BIOS settings - more correctly UEFI. A lot of installation instructions tell you to turn on a legacy boot mode but this requires a DOS-type of disk partition structure and the conflict between the two confuses the installer.

If you are able to set your 'BIOS' to uefi booting (and my installation eventually coped with secure boot too) then it would be worth reinstalling as the installer should pick this up and confirm that it's placing the bootloader in a 'system' directory (this is from memory, sorry, but in my case it was partition 2), otherwise it asks you where you want it and you (well, I) can easily give the wrong answer.

In my case I also tried to do a uefi install with a 32-bit system, and I later found that 64-bit was mandatory, but you look as though you have that sorted.

I found the following 2 articles to be very helpful and authoritative in describing how to go about a UEFI installation:

https://help.ubuntu.com/community/UEFI

Allowing boot of Ubuntu on a Acer Aspire v5-531 with UEFI

I hope these prove helpful - but in 9 months you have either been successful or given up on Linux altogether in all probability!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.