0

The 2 solutions/workarounds I found searching askubuntu didn't work so far. Going to chrome://flags and enabling Override software rendering list didn't work. Also, starting Google Chrome with "LIBGL_DRI3_DISABLE=1 google-chrome" doesn't seem to work. Chrome opens and works normally, but WebGL isn't working. I receive the following terminal output:

$ LIBGL_DRI3_DISABLE=1 google-chrome[6436:6436:0924/110923:ERROR:CONSOLE(0)] "Error in event handler for (unknown): TypeError: Cannot read property 'length' of undefined
    at chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/include.preload.js:319:20", source: https://www.google.com.br/_/chrome/newtab?espv=2&es_th=1&ie=UTF-8 (0)
[6436:6436:0924/110924:ERROR:CONSOLE(0)] "Error in event handler for (unknown): TypeError: Cannot read property 'id' of undefined
    at inject_code (chrome-extension://gkojfkhlekighikafcpjkiklfbnlmeio/js/cs_inject.js:21:13)", source: https://www.google.com.br/_/chrome/newtab?espv=2&es_th=1&ie=UTF-8 (0)
[6436:6457:0924/110924:ERROR:cert_verify_proc_nss.cc(922)] CERT_PKIXVerifyCert for goldenticket.disconnect.me failed err=-8181
[6436:6464:0924/110927:ERROR:channel.cc(307)] RawChannel read error (connection broken)

I'm using Ubuntu 14.04 and Google Chrome 45 64-bit. I have a Nvidia GeForce 730m and driver 340.76 is installed and working 100% (I can play graphically heavy games on Steam). WebGL is working on Firefox 41 (I can see a rotating cube on https://get.webgl.org/), but it's not working on Google Chrome. This is what chrome://gpu shows me:

Graphics Feature Status

  • Canvas: Software only, hardware acceleration unavailable
  • Flash: Software only, hardware acceleration unavailable
  • Flash Stage3D: Software only, hardware acceleration unavailable
  • Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
  • Compositing: Software only, hardware acceleration unavailable
  • Multiple Raster Threads: Enabled
  • Rasterization: Software only, hardware acceleration unavailable
  • Video Decode: Software only, hardware acceleration unavailable
  • Video Encode: Software only, hardware acceleration unavailable
  • WebGL: Unavailable

I guess it's not a driver related issue, since WebGL is working on Firefox. Could someone please help me getting WebGL to work on Google Chrome too? I would like to play Runescape using Chrome.

  • The problem is that you don't have hardware acceleration. Is it enabled in Settings>Advanced>Use hardware acceleration? – dadexix86 Dec 5 '15 at 19:03
0

For WebGL to work in Google Chrome (and Chromium), Here are the steps to enable WebGL in Google Chrome.

Step 1: Open Google Chrome

Step 2: Type chrome://flags in the address bar

Step 3: Press Ctrl + f and type ” Rendering list “, “Override software rendering list” should come up, Now click on Enable and restart the browser.

Step 4: Completely kill Chrome: Type killall chrome into a console.

Step 5: Start Chrome

enter image description here

Now check chrome://gpu/

enter image description here

http://webglreport.com/

enter image description here

Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.