I updated my perfectly running laptop from 11.04 to 11.10. after the upgrade graphics started to act weird. It was a heavily modified system, so I thought that was probably the issue.. so I reinstalled. I'm using the xorg-edgers ppa for updates. Unity 3D does not work... I hear ubuntu's jungle sound and then it just sits there... no icons, just a mousecursor I can move and the background picture. I have to kill X and log in to Unity 2D to get access to my desktop.

Where do I start looking for the problem? I know it's not the graphics card, it worked fine until the update.

grep -E "EE|WW" /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.365] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    14.365] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    14.365] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    14.365] (WW) The directory "/usr/share/fonts/X11/100dpi" does     not exist.
[    14.365] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    14.379] (II) Loading extension MIT-SCREEN-SAVER
[    18.758] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.

/usr/lib/nux/unity_support_test -p
OpenGL vendor string:   Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string:  2.1 Mesa 7.12-devel
Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes
Unity 3D supported:       yes

Thanks in advance for any help :-)

  • I think the latest drivers from intel were merged to 11.10 by default, try removing the edgers ppa and reinstalling the driver with sudo apt-get install --reinstall xserver-xorg-video-intel. Oct 16 '11 at 22:17
  • Ok so ended up deleting ppa, uninstalling xserver-xorg-core, and reinstalling xserver-xorg-core and xserver-xorg-video-intel. rebooting now. fingers crossed ;) Oct 16 '11 at 22:36
  • looks like it's fixed. now I'm wondering why I ended up with that edgers ppa... any post-fix checks I should be doing? Oct 16 '11 at 22:48
  • In 11.04 if you needed recent drivers you had to use ppa ones, the most recent drivers were merged in 11.10 (included) and there was a chance your ppa was overriding the default ubuntu packages. Oct 16 '11 at 22:52
  • thick the check on the answer if you agree with it. regards Oct 16 '11 at 22:54

Ubuntu 11.10 already brings the latest Intel drivers. Disable your custom PPA and reinstall the drivers:

sudo apt-get remove xserver-xorg-core
sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

According to this bug report using the xorg-edgers PPA will likely break your 3d acceleration for Unity.

  • i can't boot to the login screen now after i did this. i had the same problem
    – suli8
    Oct 19 '11 at 17:27
  • you really need to give more information for some help. Oct 19 '11 at 21:41
  • it did remove a bunch of stuff. and didn't reinstall them. i was forced to do a fresh install. i did ask a question about it. no answers.
    – suli8
    Oct 19 '11 at 23:22
  • try adding some more imformation in your questions next time. sorry Oct 20 '11 at 9:17
  • 1
    It's mentioned on their website now: IMPORTANT NOTICE 2 Unity is known to be broken with this PPA on Oneiric due to bugs.launchpad.net/ubuntu/+source/unity/+bug/860707 . Please use unity-2d, gnome-shell or some other window manager until it's fixed and I'm very sorry for the inconvenience. Oct 24 '11 at 22:33

suli8 - i had the same problem after trying brunopereira's solution.. i could no longer log in.

i don't recommend people try it. If you can no longer log in to ubuntu at all then the fix to get it back is the following:

Log into recovery console and first chose the remount option, then choose prompt with networking.

You need to set up a wired ethernet connection and reinstall xorg so type:

ifconfig etho0 up
dhclient eth0
sudo apt-get remove --purge xserver-xorg
sudo apt-get install xserver-xorg

edit: @bruno it was nothing to do with a network related problem. i used your solution and it messed up my system. simple.. and yes i can vote down an answer if i feel it is wrong that's the system here! however i actually didn't downvote your answer. peace

  • If you internet was down at the time of installing the packages that is another not related with the question issue, you could post another question about it instead of just down voting an answer that worked perfect for the user. Nov 11 '11 at 7:03
  • I couldn`t login anymore too, had to use this answer to fix the problem the first answer caused.
    – marcio
    Nov 16 '11 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.