My problem is that wireless is enabled in my router and works on other devices, the wireless switch is on in my laptop but connection only works with cable. I haven't tried logging in other networks, but the fact that I can see my nieghbours' and not mine makes me think that I could connect to theirs (if they were open!). I am next to my router but only my mobile gets online.

I can't find what is wrong. Is it possible that I have carelessly blacklisted my home network or that something was uninstalled?

I'm a beginner so let me know if there are any commands I need me to type to detect the problem. Any help is appreciated.


PS: For the command lspci -knn | grep Net -A2 the output is

04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Subsystem: Broadcom Corporation Device [14e4:04b5]
Kernel driver in use: wl
07:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express [14e4:1713] (rev 02)
Subsystem: Lenovo IdeaPad S10e [17aa:3a23]
Kernel driver in use:

I hope this helps, thanks!

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command.
    – Pilot6
    Sep 25, 2015 at 13:42

2 Answers 2


You have a wrong driver installed. Connect to the internet by wire and run in terminal

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

Maybe your wifi network is hidden and not publishing its ssid all the time. You could try to use the "Connect to hidden wifi network" entry from your network manager's menu.

You could (temporarely) disable the wifi security (I suppose you use wpa2) and try it again. Maybe you have some util not installed like wpa-supplicant.

Remember to enable wpa2 again, afterwards.

You also may try $ iw dev wlan0 scan ssid <your ssid> if your wifi is listed there, your wifi card can 'see' it.

  • Sorry for the delay getting back to you. I ran the command you suggested but still I can see only my neighbours' networks.
    – user454189
    Sep 28, 2015 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .