0

I have the following problem when running docker.io:

Running modprobe bridge nf_nat br_netfilter failed with message: modprobe: WARNING: Module br_netfilter not found.

I tried running modprobe br_netfilter which results in:

modprobe br_netfilter
modprobe: FATAL: Module br_netfilter not found.

What can I do to install br_netfilter on my system?

Thanks!

From the comments:

uname -r
3.16.0-49-generic

.

apt-cache policy linux-image-3.16.0-49-generic
linux-image-3.16.0-49-generic:
  Installed: 3.16.0-49.65~14.04.1
  Candidate: 3.16.0-49.65~14.04.1
  Version table:
 *** 3.16.0-49.65~14.04.1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status

.

find /lib/modules/ -type f -name '*br_netfilter.ko'

Did not return anything. Maybe unrelated, but I have this directory: /lib/modules/3.16.0-49-generic/kernel/net/bridge/netfilter and it contains several .ko files, but not br_netfilter.

  • Edit your question and add the output of uname -r – A.B. Sep 24 '15 at 9:39
  • And the output of apt-cache-policy linux-image-3.16.0-49-generic – A.B. Sep 24 '15 at 9:46
  • And the output of find /lib/modules/ -type f -name '*br_netfilter.ko' – A.B. Sep 24 '15 at 9:48
1

I believe you need at least Kernel version 3.19.0-15 and therefore Vivid. Check this URLs for Vivid and Trusty.

| improve this answer | |
1

For future visitors, the reason why br_netfilter fails to load is because it has been a built-in module. Only since kernel version 3.18, br_netfilter has become a separate module.

See also:

| improve this answer | |
0

I got it fixed with following command:

sudo apt-get install ebtables
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.