5

I created a script to enable flight mode at night and disable it in the morning. I'm adding checks to avoid enabling it if there is phone of web activities. The script has been added to cron (5 minute frequency to check, enable/disable every 5 minutes). It works well when the screen is up, tail on syslog shows perfect execution of the script. But, when the screen switches itself off, cron job is not run anymore. Maybe this is by design to save battery, but I guess it's possible to change it. Events like incoming call can switch the phone on, so I guess something is still running.

Any idea? Thanks

  • Maybe you find something in /etc/acpi/ , how to react to such events? Maybe it is elsewhere. – user unknown Feb 24 '18 at 7:23
0

One alternative would be to keep the system from suspending at all. You can change that in the Power settings. You can go to Brightness and Lock to set the monitor to still be turned off. As you guessed, this will use more battery

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.