0

This is not a duplicate, none of the solutions offered here could solve my problem. Basically, what happens is:

***@***:~$ sudo aptitude install pulseaudio
[sudo] password for *** : 

The following NEW packages will be installed:
  gstreamer0.10-pulseaudio{a} libfftw3-single3{a} libgomp1{ab} libpulsedsp{a} pulseaudio pulseaudio-module-x11{a} pulseaudio-utils{a} rtkit{a}

0 packages upgraded, 8 newly installed, 0 to remove and 0 not upgraded.

Need to get 1.673 kB of archives. After unpacking 6.842 kB will be used.

The following packages have unmet dependencies:
 libgomp1 : Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) but 4.8.4-2ubuntu1~14.04 is installed.

open: 25; closed: 247; defer: 17; conflict:     27  
                                                                                                                            .The following actions  will resolve these dependencies:

     Keep the following packages at their current version:
1)     libfftw3-single3 [Not Installed]                   
2)     libgomp1 [Not Installed]                           
3)     pulseaudio [Not Installed]                         
4)     pulseaudio-module-x11 [Not Installed]              



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Remove the following packages:                                                        
1)      gcc-4.8-base:i386                                                                   
2)      libdbusmenu-qt2:i386                                                                
3)      libgl1-mesa-dri-lts-vivid:i386                                                      
4)      libgl1-mesa-glx-lts-vivid:i386                                                      
5)      libjack-jackd2-0:i386                                                               
6)      libllvm3.6:i386                                                                     
7)      libqt4-dbus:i386                                                                    
8)      libqt4-declarative:i386                                                             
9)      libqt4-network:i386                                                                 
10)     libqt4-opengl:i386                                                                  
11)     libqt4-script:i386                                                                  
'12)     libqt4-sql:i386                                                                     
13)     libqt4-sql-mysql:i386                                                               
14)     libqt4-xml:i386                                                                     
15)     libqt4-xmlpatterns:i386                                                             
16)     libqtcore4:i386                                                                     
17)     libqtdbus4:i386                                                                     
18)     libqtgui4:i386                                                                      
19)     libqtwebkit4:i386                                                                   
20)     libstdc++6:i386                                                                     
21)     libtxc-dxtn-s2tc0:i386                                                              
22)     skype                                                                               
23)     skype-bin:i386                                                                      
24)     sni-qt:i386                                                                         

      Downgrade the following packages:                                                     
25)     cpp-4.8 [4.8.4-2ubuntu1~14.04 (now) -> 4.8.2-19ubuntu1 (trusty)]                    
26)     gcc-4.8-base [4.8.4-2ubuntu1~14.04 (now) -> 4.8.2-19ubuntu1 (trusty)]               
27)     libquadmath0 [4.8.4-2ubuntu1~14.04 (now) -> 4.8.2-19ubuntu1 (trusty)]               
28)     libstdc++6 [4.8.4-2ubuntu1~14.04 (now) -> 4.8.2-19ubuntu1 (trusty)]                 

      Leave the following dependencies unresolved:                                          
29)     skype-bin:i386 recommends sni-qt:i386                                               
30)     libgl1-mesa-dri-lts-vivid:i386 recommends libtxc-dxtn-s2tc0:i386 | libtxc-dxtn0:i386


Accept this solution? [Y/n/q/?] 

I know the second solution will mess up everything, and I have no idea how to work this around.

Sorry if my question violates or doesn't satisfy some criteria. I'll be glad to edit it if needed.

EDIT: I've just noticed the error

libgomp1 : Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) but 4.8.4-2ubuntu1~14.04 is installed

makes it impossible to install anything else. I've just tried installing texlive-full and kile and had it as error.

  • What's the response of a simple sudo apt-get upgrade? – Gunnar Hjalmarsson Sep 24 '15 at 1:03
  • @Gunnar Hjalmarsson it outputs: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. – Lucas Farias Sep 24 '15 at 1:07
  • Ok.. Then try: sudo apt-get install libgomp1=4.8.4-2ubuntu1~14.04 – Gunnar Hjalmarsson Sep 24 '15 at 1:45
  • The result was: 'E: Version '4.8.4-2ubuntu1~14.04' for 'libgomp1' was not found' – Lucas Farias Sep 25 '15 at 1:26
  • Open Software & Updates, select the Updates tab, and make sure that trusty-updates is enabled. Then choose Reload when closing the tool. – Gunnar Hjalmarsson Sep 25 '15 at 12:42
0

By reading the comments, It's seen that thanks to Gunnar Hjalmarsson I could solve my problem by simply going to Software & Updates and selecting "Main server" instead of using my local mirror "locaweb" (from Brazil).

Thanks, Gunnar!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.