I've downloaded mysql-workbench 5.2.35 and installed it, but when i run it, it shows only the splash screen, nothing more.

  • 1
    What happens if you invoke it from the terminal? Oct 16 '11 at 21:14
  • in the download page there are only versions for 10.10 and 11.04.. so you used the 11.04 version? maybe some library is missing?
    – Stefano
    Oct 16 '11 at 21:24
  • I have the same issue, it looks like some window refresh problem, mysql workbench is using python so maybe the python version is too new...
    – RageZ
    Oct 17 '11 at 11:08
  • Fast workaround is to press Alt+F4 when splash screen appears. Nov 19 '11 at 9:17

Here's a .deb file for Ubuntu 11.10 of MySQL Workbench, compiled from the sources with the patch applied. Works perfectly fine on my 11.10. Sorry for it being only 64-bit.


  • worked also for me!
    – Stefano
    Nov 23 '11 at 8:29
  • Is there a patch for i386 bcoz amd patch not working
    – Harssh
    May 21 '13 at 9:04

Until new builds are available, you will unfortunately need to build from source.

From the MySQL Workbench Blog:

How to build from source:

The first link has the link to the patch needed to get things working, as well as the bug report.


It’s a bug in MySQL. Close the window to go on (for instance by pressing Alt-F4).

Later, similar things happen when you open a connection. Do not press ‘Cancel’, instead close that splash window again (for instance by pressing Alt-F4).

  • I confirm that it is only needed to press ALT+F4
    – Stefano
    Nov 22 '11 at 17:07

Here is the way:

sudo add-apt-repository ppa:olivier-berten/misc
sudo apt-get update
sudo apt-get install mysql-workbench-gpl


I found something really strange. If you right click on the Mysql workbench icon on the launcher and close it, it starts! But the same thing happens when you try to open a connection to do some queries. I definitely prefer phpmyadmin.


Same problem for me and as I close it in launcher - it finally starts! Tried from terminal - after closing in launcher some warnings showed up:

Warning! Can't use connect with timeout in paramiko (George)
/bin/sh: ifconfig: not found
Log levels '0111000'

Ubuntu 64bit, recently updated from 11.04 to 11.10

MySQL workbench 64bit 5.2.35 rev7915. Didn't find for 11.10, so used mysql-workbench-gpl-5.2.35-1ubu1104-amd64.deb


I have organized an article on how to install from PPA, thanks to olivier Berten


found quick solution, if it freezes (usually on splash screens), just press Alt + F4 combination, it will simply continue (won't close your app, only splash)

ubuntu 11.10 64bit + mysql workbench 64bit 11.04


Mysql-workbench 5.2.36 is out without the splash screen problems. Have tried the 32 bit version so far and everything seems to work fine unlike 5.2.35.

Not the answer you're looking for? Browse other questions tagged or ask your own question.