330

How can I deactivate Bluetooth on system startup?

  • I don't think that "should be the natural default configuration", people are bound to want to use Bluetooth on their computers without having to turn it on (you don't seem to have a Bluetooth mouse or keyboard, if those were your primary input devices you'd want Bluetooth on from boot). However I do agree that a way to choose how you want Bluetooth to be on boot would be useful to have. – roadmr May 4 '12 at 20:25
  • 61
    The normal and natural thing is to let you choose, in the bluetooth settings, whether you want it on or off when it boots. It is not natural to have people turning it off or on every time they turn on their computer. We are talking about making Linux the best desktop system, not the worst, aren't we? – Robert May 4 '12 at 20:30
  • We agree that letting people choose is the best option. See here for some possible ways of doing this. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 – roadmr May 4 '12 at 20:31
  • 1
    This is bug #1073669. – colan Jul 14 '15 at 20:44
  • 6
    It's kind of unbelievable that, on the 14th edition, we are still "teaching" Ubuntu developers things like "the option to have bluetooth on or off on boot should be available to normal users, and not just to those fond of searching in interminable lines of public forums". – Rodrigo Aug 28 '15 at 12:08

32 Answers 32

209

18.04+ users who don't naturally have a /etc/rc.local, you'll need to create one and make it executable. To make things slightly easier, you can just paste the following command into a terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Run sudoedit /etc/rc.local and add this before line with exit 0:

rfkill block bluetooth

You should still be able to enable Bluetooth through the top bar applet.

This should work for most systems but it looks like there are a few bugs lurking in the kernel's ACPI for Thinkpads. If you're on a Thinkpad, add the following to /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Or check out ibm-acpi - IBM ThinkPad ACPI Extras Driver -- some reports suggest that ibm-acpi includes bluetooth control (amongst other nice things). But I don't have the hardware so I'm completely unable to verify these claims. Good luck.

  • 6
    For Thinkpads (and only Thinkpads) this works: echo disable > /proc/acpi/ibm/bluetooth in /etc/rc.local – Marius Gedminas Nov 2 '11 at 19:51
  • 4
    rfkill block bluetooth worked for Thinkpad T430u – bmaupin Nov 15 '13 at 16:47
  • 5
    Neither worked for me (ThinkPad x201) when I placed them one at a time in /etc/rc.local. The rfkill block bluetooth command does work, but not on startup. The -x flag is set on /etc/rc.local. I'm running Xubuntu 13.10. – Kyle Falconer Dec 20 '13 at 7:34
  • 4
    On Ubuntu 15.10 with systemd you need some more to reenable the use of the etc/rc.local file: askubuntu.com/a/696226/34298 – rubo77 Nov 10 '15 at 12:36
  • 5
    if our rc.local is just an empty file,where should we add 'rfkill block bluetooth'? – Sss Nov 25 '17 at 10:57
124

I found a how-to with a clean "workaround" here (archive link for posterity)

Actually changing /etc/bluetooth/main.conf was enough for me.

Search for the entry:

AutoEnable=true

and change the value to:

AutoEnable=false

It was enough for me, although the article describes some other steps that may or may not be necessary.

On Ubuntu 17.04 and older the option was named InitiallyPowered.

  • 3
    doesn't work for samsung laptop 530u3b, bluetooth is always on after reboot and wake up – Maxim Kim Aug 27 '12 at 18:51
  • 3
    This would only work if I also used Saeed Zarinfam's answer of putting /etc/init.d/bluetooth stop in rc.local. It seems that when the service starts up, it also brings the power on for bluetooth. I needed both to get this to work. (ThinkPad x201, Xubuntu 13.10) – Kyle Falconer Dec 20 '13 at 7:57
  • 3
    Didn't work for me on thinkpad t420 – UpTheCreek May 10 '15 at 9:40
  • 4
    "Search for the entry" is of precisely no use to those of us whose main.conf does not contain this parameter or any comment indicating its default location. So, under which [Heading] should we put it? – underscore_d Oct 30 '15 at 23:00
  • 10
    On my case it was AutoEnable=false, but anyways +1 for right solution from right place. – Arman Petrosyan Apr 20 '17 at 5:50
34

16.04+


From ubuntu 16.04 onwards systemd manages startup services like bluetooth ... to view current status issue following in a terminal

sudo systemctl status bluetooth.service 

to deactivate bluetooth on startup issue this

sudo systemctl disable bluetooth.service

then on next reboot bluetooth will not be active ... to enable bluetooth issue ( then reboot )

sudo systemctl enable bluetooth.service
  • 4
    This works for me, but as a side effect, blueman-applet stoppped to work too. It starts, but doesn't appear in the indicator area, so there is no fast way to enable bluetooth, only in terminal. – Yuri Gor Sep 2 '17 at 21:02
  • In Xubuntu, at least, if you click on Blueman, it has the option of "Turn Bluetooth Off". I think this is what the OP would like automated. Your solution removes Blueman altogether, making it harder to re-enable Bluetooth if desired. – Adrian Keister Jan 30 '18 at 14:08
  • 1
    Put sudo systemctl disable bluetooth.service && sudo systemctl stop bluetooth.service into a Disable script, and chmod 755 on it. Do the same for sudo systemctl enable bluetooth.service && sudo systemctl start bluetooth.service in an Enable script. – Adrian Keister Jan 30 '18 at 14:33
  • 2
    FINALLY! Ubuntu 18.10, the only thing that worked for me. Nothing else worked. – Tyler Feb 18 at 13:02
27

To disable the bluetooth driver from loading on startup:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

add:

blacklist btusb

Enabling it later should just be:

sudo modprobe btusb
  • 1
    Thanks for that, that does seem to work but I was trying to avoid command line stuff as per my original question. You would think this would be as simple as ticking a box so that it remembered that I don't want BT to start automatically but it looks like its way more complicated than that. With Ubuntu's drive for quicker boot times and the general focus on power consumption in laptops and netbooks I am suprised that this has never been addressed. I appreciate the help though. – Chris Giltnane Aug 19 '10 at 9:52
  • 9
    "Run gedit as root and edit /etc/modprobe.d/blacklist.conf" <-- ok, is that less command line for ya? – maco Aug 19 '10 at 13:35
  • 1
    Works fine on Samsung Q35 with Ubuntu 13.10, while the 'rfkill block bluetooth' approach does not. Thanks! – user27164 Jan 6 '14 at 8:29
  • DELL E6410 works for me. Good that can run again on the go without reset. – Ruslan Gerasimov Jun 13 '14 at 10:24
  • Don't bother trying to "avoid command line stuff" when you are configuring the operating system. Is Ctrl+Alt+T and a couple of ctrl-shift-V (to paste) too much to ask? – doug65536 Aug 8 '16 at 0:15
18

Step 1: Go to the terminal and type in the following command to edit system's /etc/rc.local file:

gksudo gedit /etc/rc.local

Step 2: Add the following line before the exit 0 line:

rfkill block bluetooth
  • 1
    This is set soft block to bluetooth, I think it same as turn off its service and works well. – Smile.Hunter Aug 17 '12 at 13:45
  • @Robert: $ man rfkill: "Disable the device corresponding to the given index." Despite the name, it is only disabling BT; just try the command rfkill block bluetooth on the terminal, you should see the icon go gray. – Daniel Jun 13 '15 at 17:54
8

Type the following into a terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

At the bottom of the file, add the line:

blacklist bluetooth

Save the file and restart - Bluetooth should now be disabled.

  • This won't work on my pc... – Floqqi Oct 16 '11 at 21:47
  • @Floqqi: Can you please try it again? I've updated my answer. – Nathan Osman Oct 16 '11 at 23:42
  • 2
    Tried about 20 things on my ubuntu 12 thinkpad, this is the only one that did the trick. – OlivierBlanvillain Sep 12 '13 at 16:57
8

1. block bluetooth in rc.local

Add this line at the end of the file /etc/rc.local right before the line exit 0:

rfkill block bluetooth

This will do the trick, but only in older Ubuntu versions using upstart.

2. reenable rc.local on systemd

On Ubuntu 15.10 with systemd as startup manager the /etc/rc.local file is not used by default any more, so call this on a terminal:

sudo systemctl edit --full rc-local

Which opens an editor. At the end of the file i added:

[Install]
WantedBy=multi-user.target

Those changes are activated by

sudo systemctl reenable rc-local

Now the file /etc/rc.local is used as you know it.

3. disable blueman-applet on start

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Now blueman-applet is visible and you can disable it from startup programs

4. Reboot to see the effect

  • 3
    For me on Ubuntu 17.04 with blueman: gsettings set org.blueman.plugins.powermanager auto-power-on false worked, from wiki.archlinux.org/index.php/Blueman. Although I ended up doing sudo apt remove blueman then manage bluetooth through system settings and check "Show Bluetooth status in the menu bar". Blueman starting and turning on bluetooth was the issue. – M J Sep 28 '17 at 14:29
7

You can change the services started at boot with the help of BUM.

Install it: sudo apt-get install bum

Run: sudo bum

enter image description here

Uncheck the box and click Apply.

  • Thank you, desgua, I was thinking about this kind of tools. I have used some in the past but they become obsolete and the new ubuntu, with their minimalistic obsession, comes with nothing of the kind. Is this the only yo know or the best yo know? – Robert May 5 '12 at 0:15
  • 1
    Maybe works but at first it has disappointed me because it started showing the bluetooth as not activated at boot time, why? and as not running when rfkill, the applet and hciconfig show it running. I turn off and on but bum continues showing the service as off. I activated the service at boot-up but the status of the service continues to be wrong. – Robert May 5 '12 at 1:26
  • sorry doesn't work on elementaryOS Freya – Hoang Tran Jul 9 '16 at 13:31
  • I get lots of "use of uninitialized value" warnings when it runs. Sorry, can't trust that. – doug65536 Aug 8 '16 at 0:21
  • Now, the package is not available. It say, Bum is virtual. – Satya Prakash Jul 26 '17 at 19:27
6

I add

"/etc/init.d/bluetooth stop"

into

"/etc/rc.local" 

before "exit 0" command for boot with bluetooth turned off.

  • This removed the bluetooth tray icon but left my bluetooth indicator light on (indicating power was still being sent to the radio). Edit: this in conjunction with Stepbaer's answer (InitiallyPowered = false) worked for me. (ThinkPad x201, Xubuntu 13.10) – Kyle Falconer Dec 20 '13 at 7:59
  • this did not work on my 64-bit Ubuntu 14.04 dell inspiron. Only rfkill worked for me. – faizal Jun 17 '14 at 7:19
5

I think that the best way is to disable the service from being started in the first place. There is a general method for disabling services which works perfectly:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

That works for Ubuntu 13.10 and probably for earlier versions as well.

  • how to turn on bluetooth, while using provided settings later on? say I want to use it just for 5 min. every 10 boots.. – b1r3k Oct 10 '15 at 14:51
4

You can edit your update-rc.d settings. I used something similar to:

sudo update-rc.d bluetooth remove

In Debian Wheezy. Check out man update-rc.d for more info on how to use it.

4

I found another answer using tlp that works great for me with Ubuntu 18.04. Probably first tlp must be installed with

sudo apt install tlp

Then the file

/etc/default/tlp

contains some settings about devices like wifi and bluetooth. There is the key

RESTORE_DEVICE_STATE_ON_STARTUP

which is by default set to 0. After I switched it to 1 my last setting is remembered on the next boot. That means when I disable bluetooth in the top panel it stays disabled and when I enable bluetooth it stays enabled. Also there is the key

DEVICES_TO_DISABLE_ON_STARTUP

which can be set to

DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"

Now bluetooth will be disabled on each boot. After changing this configuration bluetooth will can be enabled and disabled through menu and panel item. I think it's better than removing it from kernel modules.

  • TLP is not installed by default in Ubuntu. You should update your post accordingly. – linrunner Feb 11 at 17:07
  • @linrunner Ok, didn't know what that. I tested on a fresh Ubuntu Budgie from Tuxedo. There it worked. I fixed my answer. – Thomas Sablik Feb 11 at 18:07
  • using tlp is a sensible answer since laptop users surely all install it. – Tim Richardson May 4 at 1:34
2

Maybe you can turn it off in the Startup Applications. But these applications are hidden by default. Unhide the hidden Startup Applications in 12.04: Open the terminal and run these two commands:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Now you can uncheck bluetooth. (Don't remove!)

  • Bluetooth is not listed among these applications, sadly. – pfctdayelise Jul 10 '15 at 12:11
2

No. It is not always in the startup applcations list. I think that the best solution is to add the rfkill command in rc.local script or to set the InitiallyPowered parameter in /etc/bluetooth/main.conf.

  • 1
    InitiallyPowered seems to be ignored for me. – UpTheCreek May 10 '15 at 9:42
2

1) Install the package smbios-utils and add it to Startup Applications with:

sudo smbios-wireless-ctl --bt 0

2) In terminal type:

sudo visudo

and add to the end of opened file /etc/sudoers the line:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) To switch bluetooth on during session, run in terminal:

sudo smbios-wireless-ctl --bt 1

This works for me on my Dell D630 with Ubuntu 13.10

  • Do you think that sudo smbios-wireless-ctl --boot --bt 0 would work? Also, I'm not sure, but this may be Dell-specific. – Hitechcomputergeek May 2 '15 at 18:48
  • Actually, the package smbios-utils performs bios commands, so it switches on and off physical devices related to bios, so you may also use it to switch on and off wifi etc. I'm not sure if it works with any bios or not. At least, it works well with Dell. By the way, the last installations of Ubuntu 14.04 do same things with bluetooth and wifi applets, so I don't need any more in that package. – victor May 3 '15 at 19:22
  • I knew that. But if you do smbios-wireless-ctl --help, part of it has --boot Set BIOS boot-time setting. I didn't know they fixed the Bluetooth, though; thanks for telling me. – Hitechcomputergeek May 4 '15 at 21:29
2

On Ubuntu 16.04, I simply disabled the service from starting up using systemctl.

To do this, open up a terminal window and type the following:

sudo systemctl disable bluetooth

You can either reboot since now bluetooth will be disabled from starting up, or if you do not want to reboot and want to stop bluetooth right away, you can type:

sudo service bluetooth stop

2

On Ubuntu Studio 16.04 you can disable Bluetooth Applet in Startup in:

Session and Startup > Application Autostart > Bluetooth Applet

Here you can click in the field to disable it.

  • This is a perfectly good solution on my Xubuntu 17.10 machine, except for one thing: if the user wants to start using bluetooth again on the fly, he needs to execute sudo systemctl enable bluetooth.service && sudo systemctl start bluetooth.service. But your solution definitely solves the bootup problem. – Adrian Keister Jan 30 '18 at 14:52
2

We can disable bluetooth auto start this way:

sudo gedit /etc/bluetooth/main.conf

(gedit is my fav editor, you can replace this with xed or whatever that's installed on your system.)

At the very bottom of this file, there's this line:

#AutoEnable=false

Un-comment it, like this:

AutoEnable=false
  • doesn't work in ubuntu budgie 18.04 – Argento Sep 3 '18 at 13:27
2

If you're using the Bluetooth applet in the top panel (blueman-applet), it has its own setting that will automatically turn Bluetooth on even if you've disabled it in other places (like /etc/bluetooth/main.conf or /etc/default/tlp).

To prevent Bluetooth from turning on at startup using the command line:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Or through the GUI:

  1. Click the Bluetooth applet > Plugins > PowerManager > Configuration
  2. Uncheck Auto power-on

Next time you reboot, the Bluetooth applet will still be visible but Bluetooth will be off. To turn it on:

Click the Bluetooth applet > Turn Bluetooth On

  • In Ubuntu 18.04 this is the only solution I have found. Even if you change in /etc/bluetooth/main.conf, at the bottom, the option from AutoEnable=true to AutoEnable=false you cannot turn off the Bluetooth. In fact this option is for discovering new devices not for powering Bluetooth on or off. – Alessandro D'lncal Aug 19 '18 at 12:26
1

I using Sputnik Kernel, which fixed this on my Dell Inspiron 14R N4110.

1

I think you should edit

/etc/default/bluetooth

and set

BLUETOOTH_ENABLED=0

to disable the bluetooth service at boot

  • 1
    did not work on Ubuntu 14.04 – b1r3k Sep 27 '15 at 17:28
1

For those of you where inserting the line rfkill block bluetooth (or any other) in /etc/rc.local doesn't work, try to include the same line in the end of ~/.bashrc

In my set up (Ubuntu 14.04, Thinkpad W540), no option worked inserting it in /etc/rc.local but the former did work in bashrc. Note this will work just for the current user, not globally for all users.

1

Since Ubuntu 18.04 (with GNOME) you need to

  1. Edit /etc/bluetooth/main.conf and find

    AutoEnable = true
    

    and change the value to:

    AutoEnable = false
    

    So this device is not powered on startup.

  2. Edit /etc/default/tlp and find:

    #DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"
    

    Edit this line to read:

    DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"
    

    So this device is disabled on startup.

  3. Then open Dash and search for "Startup Applications". Uncheck any items related to Bluetooth in the list. Click [Close] to save.

  • Point 4: Go to Settings -> Bluetooth -> Disable (at top right window). – Omar Tariq Jan 27 at 6:43
0

I add

"/etc/init.d/bluetooth stop"

into

"/etc/rc.local" 

before "exit 0" command for boot with bluetooth turned off.

0

Solution for my notebook

"BIOS - USB Configuration - EHCI2 : Disabled"

EHCI1 is for usb ports (actually My notebook has 2 usb 2.0 ports)

0

Edit /etc/default/grub:

sudo nano /etc/default/grub

and change the following line:

GRUB_CMDLINE_LINUX=""

to say this instead:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Then, update grub and reboot:

sudo update-grub
0

This should disable bluetooth from starting on Debian based systems:

sudo chkconfig bluetooth off

or on RedHat based systems

systemctl disable bluetooth.service
0

Unfortunately, nothing above work for me. Instead, I add this to the bottom line of ~/.profile

( sleep 10; rfkill block bluetooth ) & 

In my case, I must wait for the blueman applet to start and enable bluetooth(unavoidably) before I could switch it off.

0

Pure systemd solution (16.04+)

Rather than use the legacy rc-local solution, here is a clean and portable systemd service that suspends bluetooth upon boot and also after waking up from sleep.

  1. Using sudo, create /etc/systemd/system/bluetooth-suspend.service with the following contents:
[Unit]
Description=Disable bluetooth after waking up.
After=suspend.target network.target

[Service]
User=root
Environment=DISPLAY=:0
ExecStart=/usr/sbin/rfkill block bluetooth

[Install]
WantedBy=suspend.target network.target
  1. Enable the service: sudo systemctl enable bluetooth-suspend.service

  2. Reload systemd: sudo systemctl daemon-reload

To re-enable bluetooth, run rfkill unblock bluetooth in the terminal.

-1

I had to use a brute-force method to stop bluetoothd from being automatically started at boot. I renamed the executable so it couldn't be found.

  • It's faster starting things in parallel. At least that's the idea. – Douglas Leeder Sep 28 '12 at 13:48

protected by Community Oct 15 '14 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.