5

How to start firefox in safemode using terminal,Because I don't see any safemode option for firefox in Ubuntu

4

Open a terminal (Ctrl+Alt+T) and run :

firefox -safe-mode

Do not forget to close any Firefox instance before running this command.


Refer here for more information.

Or show all options via

firefox --help

Usage: firefox [ options ... ] [URL]
       where options include:

X11 options
  --display=DISPLAY  X display to use
  --sync             Make X calls synchronous
  --g-fatal-warnings Make all warnings fatal

Firefox options
  -h or --help       Print this message.
  -v or --version    Print Firefox version.
  -P        Start with .
  --profile    Start with profile at .
  --migration        Start with migration wizard.
  --ProfileManager   Start with ProfileManager.
  --no-remote        Do not accept or send remote commands; implies --new-instance.
  --new-instance     Open new instance, not a new window in running instance.
  --UILocale  Start with  resources as UI Locale.
  --safe-mode        Disables extensions and themes for this session.
  --jsconsole        Open the Browser Console.
  --jsdebugger       Open the Browser Toolbox.
  --start-debugger-server [port|path] Start the debugger server on a TCP port or Unix domain socket path.  Defaults to TCP port 6000.
  --browser          Open a browser window.
  --new-window  Open  in a new window.
  --new-tab     Open  in a new tab.
  --private-window  Open  in a new private window.
  --preferences      Open Preferences dialog.
  --search     Search  with your default search engine.
  --recording  Record drawing for a given URL.
  --recording-output  Specify destination file for a drawing recording.
  --setDefaultBrowser Set this app as the default browser.

      -g or --debug          Start within debugger
      -d or --debugger       Specify debugger to start with (eg, gdb or valgrind)
      -a or --debugger-args  Specify arguments for debugger
  • was enough to let it fix itself, I just restarted w/o safemode and it worked again (with some extensions that got auto-disabled as I did nothing in safemode) thx! – Aquarius Power May 26 '17 at 18:32
2

You can open Firefox in safemode, but you can't directly see the safe mode option.

  1. Open Firefox.

  2. Open the menu.

  3. At the bottom of the menu you will see a ? (help) - click on it.

  4. Select start with add-ons disabled.

A pop-up appears.

Imgur

Click on restart.

Now another pop-up appears.

Imgur

Click on start in safe mode.

0

Hold Shift while Firefox is starting. A dialog will appear with two buttons: Start in Safe Mode and Refresh Firefox.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.