1

Some Gedit plugins (for example codecomment) are not working after upgrading from version 12.04 to 14.04. When I go in Preferences->Plugins and check the box of one of those plugins, I get a message on the terminal :

(gedit:15457): libpeas-WARNING **: Could not find loader 'python3' for plugin 'codecomment'

I already tried to edit the file /usr/lib/x86_64-linux-gnu/gedit/plugins/codecomment.plugin to change Loader=python3 to Loader=python as suggested in other posts, but it doesn't fix the problem, I get the message

libpeas-WARNING **: Could not find loader 'python' for plugin 'codecomment'

I have python3 correctly installed. Does anyone know how to fix this, seems to be around for quite long time.

Update: the problem does not appear when I start gedit from the Applications menu, but only when I start gedit from a terminal.

  • 2
    Possible duplicate? askubuntu.com/questions/61785/… – fossfreedom Sep 22 '15 at 22:41
  • look & see if there is a /usr/lib/gedit/plugins folder. The location changed from 12.04 to 14.04, maybe it was left behind & interfering somehow . Also try in a guest session to see if gedit performs as expected there. – doug Sep 22 '15 at 23:26
  • Indeed there is no /usr/lib/gedit/plugins folder. My plugins are still located in /usr/lib/x86_64-linux-gnu/gedit/plugins. Also, in a guest session gedit works well. What do you suggest to do? – gg-79 Sep 23 '15 at 8:52
  • I also tried to uninstall Gedit and the plugins, and re-install. Still missing the folder /usr/lib/gedit/ and the plugins not working – gg-79 Sep 23 '15 at 9:06
  • You don't want /usr/lib/gedit. Seeing that a guest session works then you have some local config or setting that is borking this up for you. That's one of the downsides to upgrading over such a large timeframe, things change. I'd look in home folder/.gconf, see if anything to do with gedit is in there. If so remove. Also maybe see what's in ~/.config/gedit/, there should be nothing to do with plugins in there. (in 14.04 gedit saves those settings in gsettings(dconf. Worst case you could just reset dconf to new install defaults & reset your preferences (will extend to other app's settings – doug Sep 23 '15 at 22:59
2

I found the problem: in the file .bash_rc I had the LD_LIBRARY_PATH set to some Matlab libraries. Commenting this line solve the problem (not sure why though).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.