I just installed Linux and since the installation process (so, this was occurring already in the setup wizard for Ubuntu) I've had the issue where my Ethernet adapter exists and is correctly identified and associated a driver to, but it simply doesn't want to connect to my network. It keeps signaling me that it is connecting but simply doesn't.

If I ping my router (, in this case):

griffrez@KikoPCLinux:~$ ping
connect: Network is unreachable

ifconfig output (the usb0 interface is because I'm tethering Internet access using my phone, through USB, but I've left it anyway, in case it is relevant [network wasn't working even before starting to tether].):

griffrez@KikoPCLinux:~$ sudo ifconfig -a
eth0      Link encap:Ethernet  HWaddr 1c:87:2c:72:d5:ce  
          inet6 addr: fe80::1e87:2cff:fe72:d5ce/64 Scope:Link
          RX packets:142 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9856 (9.8 KB)  TX bytes:6358 (6.3 KB)
          Interrupt:20 Memory:f7100000-f7120000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2688 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2688 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:330817 (330.8 KB)  TX bytes:330817 (330.8 KB)

usb0      Link encap:Ethernet  HWaddr 02:57:00:53:38:34  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::57:ff:fe53:3834/64 Scope:Link
          RX packets:7518 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6451 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6112425 (6.1 MB)  TX bytes:1136283 (1.1 MB)

Under lspci's output there's one relevant entry:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V (rev 05)

lshw's output:

griffrez@KikoPCLinux:~$ sudo lshw -C network
       description: Ethernet interface
       product: Ethernet Connection (2) I218-V
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 05
       serial: 1c:87:2c:72:d5:ce
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.1-4 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:27 memory:f7100000-f711ffff memory:f7138000-f7138fff ioport:f040(size=32)
       description: Ethernet interface
       physical id: 1
       logical name: usb0
       serial: 02:57:00:53:38:34
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip= link=yes multicast=yes

Anyway, any other command you may think you need to help me troubleshoot this, just ask, and I'll be happy to provide it.

Thanks for any future assistance.

  • I had an issue like this when as well when I first installed the OS. I spent a about an hour trying to figure out why it wasn't working, however, it turns out mine was an OS issue. Something didn't install right and therefore I reinstalled the OS. It begin to work afterwards. Have you tried to reinstall the OS? Sep 22, 2015 at 23:13
  • @Harley I have reinstalled the operating system a few times. Never worked. Also I would like to note that my network access is fine on Windows. Sep 23, 2015 at 8:43

1 Answer 1


Well the ping does not work because your eth0 interface only has an ip6 address. You probably should try to ping your router using ip6 with ping6 <your routers ip6 address or hostname>

If you want to use ip4 in your local network, you should configure your dhcp server (I suppose your local network is initialized using dhcp). Usually that should be part of the router configuration.

In general you can check $ route -n to see all the networks that you can reach.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .