3

Today I received my new convertible device, a HP Pavilion x2 10-n015n, which came preinstalled with Windows 8.1 32bit.

As I'd like to - at least testwise - install Ubuntu GNOME on it, I created a bootable USB stick with the 14.04 LTS ISO of Ubuntu GNOME. However, when trying to boot it, I only receive the following message:

The selected boot device failed. Press <Enter> to continue.

What I've tried so far:

  • Disable fast boot in Windows
  • Disable Secure Boot in the BIOS settings
  • Searched for an option to enable Legacy booting, but there is none
  • Used both UnetBootin and Ubuntu's Startup Disk Creator
  • Used two different USB drives
  • Tried both the 32bit and 64bit image of Ubuntu GNOME
  • Verified checksums (although it shouldn't be necessary using BitTorrent)
  • Also tried the "normal" Ubuntu (also 14.04), in case Ubuntu GNOME didn't yet support UEFI.
  • On my main computer (no UEFI, no Windows), the live system booted without problems each time.
  • Tried creating the bootstick using Rufus (both GPT and MBR parttables, both ISO and dd mode), as suggested by Raphael.

None of these helped me:

Do you have any idea why the USB won't boot or what can be done about it?

2

Ok, here is what I've found out:

The system has a 32bit UEFI, while Ubuntu (and all other distros I know) currently only supports 64bit UEFI. I managed to do the following:

  • Create a bootable Ubuntu USB stick using UnetBootin.
  • Download the latest rEFInd binary and installed it manually to the USB stick according to the instructions in rEFInd's online manual.
  • Create an entry in rEFInd's config file, equivalent to the "Try without installing" GRUB entry.
  • Reboot the system and manually select rEFInd's 32bit EFI executable.
  • Select the created menu entry and boot it.

rEFInd now tries to boot the live system. As I removed the quiet splash options, I could see the boot log. However, after a few seconds, the screen turned black. I have not yet found out where the black screen comes from or what causes it, but I doubt it is an X11 issue, as Ctrl+Alt+Del reboots the system, which wouldn't happen if the graphical environment were running. But I managed to boot the kernel from the live system, which technically could count as booting the live system ;)

However, I decided not to try installing Ubuntu any further, but I think this procedure can be helpful if someone else runs into a similar problem.

UPDATE: After some more annoyances by Windows, I tried again. The solution for the black screen was simple: Added the nomodeset argument to the boot options, and the system properly booted.

However, half of the device's hardware, including both WiFi and Bluetooth adapters, is not recognized (I'm not talking about no drivers, I'm talking about not even found by the system, e.g. listed in lshw).
So I guess I'll have to stick to Windows, then.

0

That's an issue with the bootable pendrive, try using a different software to create the bootable medium such as: PendriveLinux or Rufus since you are on windows currently.

Hope this helps!

  • Actually, I'm currently on Linux on my main computer. I try to avoid Windows as much as possible, but your idea might indeed work. I'll try and report back. – s3lph Sep 22 '15 at 14:50
  • Report back if it works!!! – Raphael Sep 22 '15 at 14:51
  • Nope, doesn't work when using Rufus... – s3lph Sep 22 '15 at 18:18
0

In settings of UEFI/EFI-Bios you can adjust which boot-mode is active - there is "legacy-boot-mode" and there is the more simple plain "boot-mode" - either the one or the other is active and can be enfluenced. In former Bios (before UEFI or EFI came up) there was key F12 or key F9 with which one could select, which device to boot, but this was depending on whether the Bios recognized this device before. In UEFI/EFI you could try to deactivate legacy-boot-mode, but in case USB-device is brandish-newer than Bios then you need to update Bios.

  • If you read through the list of things I've tried, you'll see that I already searched for this in the settings, but the UEFI of this device doesn't seem to implement Legacy support any more. Also I've tried various sticks of different age. – s3lph Sep 22 '15 at 18:56
  • @the_Seppi - hm ... are you sure you have set the boot-flag on the usb-sticks after formatting the usb-sticks with gparted ?! - should work then, in case if this works not, then try to re-install gparted. – dschinn1001 Sep 22 '15 at 19:00
  • I found the issue: The device has a 32bit UEFI. I'll try booting the image by putting rEFInd on the stick, which should have a 32bit EFI binary. – s3lph Sep 22 '15 at 19:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.