0

I tried to install Viber on my 32-bit Ubuntu 14.04 laptop. I installed wine and downloaded viber.exe file. Then I tried to install viber with wine, but the installation stops and outputs:

One or more issues caused the installation to fail. Please fix the issues and try again.

Then they have attached this log file :

----------


[0029:002A][2015-09-22T15:50:28]i001: Burn v3.9.1208.0, Windows v6.2 (Build 9200: Service Pack 0), path: Z:\home\poshan\ViberSetup.exe, cmdline: '-burn.unelevated BurnPipe.{7228FF2A-2A3C-4046-A2D5-7EE95BA1AFB3} {4AA84B10-3FFA-4C50-9459-81847BF37C0F} 38 '
[0029:002A][2015-09-22T15:50:28]i000: Initializing string variable 'InstallFolder' to value '[LocalAppDataFolder]\Viber\'
[0029:002A][2015-09-22T15:50:28]i000: Setting string variable 'WixBundleLog' to value 'C:\users\poshan\Temp\Viber_20150922155028.log'
[0029:002A][2015-09-22T15:50:28]i000: Setting string variable 'WixBundleOriginalSource' to value 'Z:\home\poshan\ViberSetup.exe'
[0029:002A][2015-09-22T15:50:28]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'Z:\home\poshan\'
[0029:002A][2015-09-22T15:50:28]i000: Setting string variable 'WixBundleName' to value 'Viber'
[0029:002F][2015-09-22T15:50:28]i000: Setting version variable 'WixBundleFileVersion' to value '5.3.0.1884'
[0029:002A][2015-09-22T15:50:28]i100: Detect begin, 1 packages
[0029:002A][2015-09-22T15:50:28]i101: Detected package: ViberSetup.msi, state: Absent, cached: None
[0029:002A][2015-09-22T15:50:28]i199: Detect complete, result: 0x0
[0029:002F][2015-09-22T15:50:32]i000: Setting numeric variable 'EulaAcceptCheckbox' to value 1
[0029:002A][2015-09-22T15:50:32]i200: Plan begin, 1 packages, action: Install
[0029:002A][2015-09-22T15:50:32]i052: Condition 'VersionNT>=v6.1' evaluates to true.
[0029:002A][2015-09-22T15:50:32]i000: Setting string variable 'WixBundleRollbackLog_ViberSetup.msi' to value 'C:\users\poshan\Temp\Viber_20150922155028_0_ViberSetup.msi_rollback.log'
[0029:002A][2015-09-22T15:50:32]i000: Setting string variable 'WixBundleLog_ViberSetup.msi' to value 'C:\users\poshan\Temp\Viber_20150922155028_0_ViberSetup.msi.log'
[0029:002A][2015-09-22T15:50:32]i201: Planned package: ViberSetup.msi, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
[0029:002A][2015-09-22T15:50:32]i299: Plan complete, result: 0x0
[0029:002A][2015-09-22T15:50:32]i300: Apply begin
[0029:002A][2015-09-22T15:50:38]i000: Caching bundle from: 'C:\users\poshan\Temp\{e577cb09-2068-44fb-8eed-cfcc1617b010}\.be\ViberSetup.exe' to: 'C:\users\poshan\Local Settings\Application Data\Package Cache\{e577cb09-2068-44fb-8eed-cfcc1617b010}\ViberSetup.exe'
[0029:002A][2015-09-22T15:50:44]e000: Error 0x80070005: Failed to cache bundle from: 'C:\users\poshan\Temp\{e577cb09-2068-44fb-8eed-cfcc1617b010}\.be\ViberSetup.exe' to 'C:\users\poshan\Local Settings\Application Data\Package Cache\{e577cb09-2068-44fb-8eed-cfcc1617b010}\ViberSetup.exe'
[0029:002A][2015-09-22T15:50:44]e000: Error 0x80070005: Failed to cache bundle from path: C:\users\poshan\Temp\{e577cb09-2068-44fb-8eed-cfcc1617b010}\.be\ViberSetup.exe
[0029:002A][2015-09-22T15:50:44]e000: Error 0x80070005: Failed to begin registration session.
[0029:002A][2015-09-22T15:50:44]e000: Error 0x80070005: Failed to register bundle.
[0029:002A][2015-09-22T15:50:44]i399: Apply complete, result: 0x80070005, restart: None, ba requested restart:  No


--------

What should i do?

4
  • Viber has an Ubuntu client. See here viber.com/en/products/linux
    – Promille
    Sep 22, 2015 at 10:15
  • @Wildcard don't mind- I see only for 64-bit not 32-bit
    – Ravan
    Sep 22, 2015 at 10:21
  • Is wine ViberSetup.exe the command you used to install wine after downloading
    – Ravan
    Sep 22, 2015 at 10:25
  • yes, i installed wine and downloaded viber and used the command wine ViberSetup.exe Sep 22, 2015 at 10:35

1 Answer 1

2

Viber has a Linux version. It is lot easier to install and use than using the Windows version through Wine.


To install Viber on Ubuntu open a terminal (Ctrl+Alt+T) and run :

wget http://download.cdn.viber.com/cdn/desktop/Linux/viber.deb
dpkg -i viber.deb
9
  • does that work for 32-bit? Sep 22, 2015 at 10:36
  • Right... I don't think so... Can you try ? I do not have a 32-bit system
    – hg8
    Sep 22, 2015 at 10:38
  • i am trying, i'll let you know.. Sep 22, 2015 at 10:38
  • i downloaded the file but when i typed in the second command it says this dpkg: error: requested operation requires superuser privilege Sep 22, 2015 at 11:23
  • sudo dpkg --force-architecture -i viber.deb use this command inplace of second command, ....comment result
    – Ravan
    Sep 22, 2015 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.