I've been trying to update Ubuntu from 11.04 to 11.10 through Update Manager multiple times since the release but have encountered this error every single time:

An unresolvable problem occurred while calculating the upgrade: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

This can be caused by: * Upgrading to a pre-release version of Ubuntu * Running the current pre-release version of Ubuntu * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal.

The apt.log contains a lot of messages similar to:

Investigating (8) gnome-control-center [ amd64 ] < 1:2.32.1-0ubuntu15 -> 1:3.2.0-0ubuntu6 > ( gnome )
Broken gnome-control-center:amd64 Depends on libgnome-desktop-3-2 [ amd64 ] < none -> 3.2.0-0ubuntu4 > ( libs ) (>= 3.1.2)
  Considering libgnome-desktop-3-2:amd64 47 as a solution to gnome-control-center:amd64 22
  Holding Back gnome-control-center:amd64 rather than change libgnome-desktop-3-2:amd64

Any ideas what I can do to resolve this?

  • Are you completely up-to-date on the regular updates? – bntser Oct 16 '11 at 19:11
  • Yes, I've installed all avaliable updates, and also tried disabling all non-Ubuntu sources (PPAs). – JLinden Oct 16 '11 at 19:14

Had a similar issue. I then found this thread - removing the ia32-libs package as rockorequin suggested solved my problem.

| improve this answer | |
  • This did the trick! Just for reference for others: This might remove a few of your applications you'll have to reinstall after the upgrade. – JLinden Oct 18 '11 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.