I'm using Ubuntu 14.04 LTS. When I try to update my system, i get the following error message:

Software Updater - Not all updates can be installed

I googled and some suggested to fix the broken packages using sudo apt-get install -f. But that did not work for me.

When I use apt-get upgrade this is the message I receive:

Reading package lists...
Building dependency tree...
Reading state information...
The following packages have been kept back:
  gir1.2-rb-3.0 gir1.2-totem-1.0 librhythmbox-core8 libtotem-plparser18 libva1
  libvlc5 libvncserver0 linux-generic-lts-utopic
  linux-headers-generic-lts-utopic linux-image-generic-lts-utopic rhythmbox
  rhythmbox-data rhythmbox-mozilla rhythmbox-plugin-cdrecorder
  rhythmbox-plugin-magnatune rhythmbox-plugins smplayer smplayer-themes totem
  totem-common totem-mozilla totem-plugins vlc vlc-data vlc-nox
  vlc-plugin-libde265 vlc-plugin-notify vlc-plugin-pulse
The following packages will be upgraded:
  google-chrome-stable mkvtoolnix mkvtoolnix-gui
3 upgraded, 0 newly installed, 0 to remove and 28 not upgraded.
Need to get 53.3 MB of archives.
After this operation, 6,539 kB disk space will be freed.
Do you want to continue? [Y/n] Abort.

What i don't get is why the linux kernel image has the name linux-image-generic-lts-utopic(Why does it contain the word utopic, even though the code name is trusty)? I also looked at the /etc/apt/sources.list. There is no occurrence of the word utopic in it.

Things I have tried

  1. Fix Broken Packages using apt-get install -f
  2. The commands : apt-get autoremove && apt-get clean && apt-get update

What can i do to make the System Updater to work normal? Thanks in advance

  • 6
    Have you tried sudo apt-get dist-upgrade? – snoop Sep 22 '15 at 3:42
  • @snoop No. I did not try with dist-upgrade. Let me check with it. – Kenpachi Sep 22 '15 at 3:50
  • Maybe you accidentally added repositories from Utopic Unicorn? Check your software repositories to see if that is the case. They should only show trusty and not utopic – Rewarp Sep 22 '15 at 6:23
  • 1
    @Rewarp Like i mentioned in the question, there is no occurrence of the word utopic in sources.list file. – Kenpachi Sep 22 '15 at 6:30

The problem got solved after running sudo apt-get dist-upgrade.

What does this do?

From apt-get man page:

dist-upgrade in addition to performing the function of upgrade, also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. The dist-upgrade command may therefore remove some packages.

  • 18
    indeed! Worth mentioning that it does not upgrade ubuntu, but only fixes dependencies of installed applications. thanks – Amir Uval Dec 12 '16 at 9:52
  • This helped, thank you. I had a setting set psmouse.synaptics_intertouch=1 which prevented upgrades. Commenting it out and running sudo apt-get install -f solved the problem. – Sebastian G. Marinescu Oct 26 '18 at 4:59
  • fantastic !!!!! – Mr.P Apr 1 '20 at 3:16
  • No idea why this is not made clearer what this does and why it not offered as part of the upgrade to 20.04 but rather the error message of this OP will show after the upgrade ... – matanster Jun 18 '20 at 10:02
  • Had the same problem and used this solution. However it killed my MySQL installation and I had to re-install. – Sherri Jun 9 at 13:39

I was able to get past this issue, as per a post elsewhere on the net (forget where), by using Synaptic to upgrade my packages. Afterwards, the software updater was no longer complaining, and could fetch/install the updates since then.


I would do further checks in /etc/apt/sources.list or via y-ppa-manager or via Software and Updates temporarily uncheck some repos or sources which temporarily may contain some newer packages with broken dependencies or assign the version of Your Ubuntu as each source repo extension to be sure install e.g. only 'trusty' not 'utopic' version. Usually this is kind of issue occured for some time if personal PPAs are in use and then is fixed by updated software makers either on official Ubuntu side or software provider. If the breakening seems permanent then the solution mentioned above may be needed. Maybe You use custom Rhythmbox or Vlc PPAs? Surely Synaptic seemes in many ocassions still more clear and transparent.


I have used this command and it solved my issue:

sudo dpkg --configure -a  

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.