66

I've bought a Philips SHB4000 headset (phone+mic) wireless (bluetooth) and It has a good quality when I pair it with my phone or PC Windows but when I pair it with the same PC on Ubuntu (14.10 64 bits) the sound quality goes down.

I've been googling about but I haven't found any convincing answer.

Tks in advance! ....

  • 6
    Sounds like you are using the HSP/HFP instead of A2DP, go into sound settings, then see what the SHB4000 is using – Jeremy31 Sep 21 '15 at 23:45
  • I had loud sound while I was changing to A2DP... I got a fright! :P Tks! Now it works with good quality! – Cleber Marques Sep 22 '15 at 0:05
  • Same problem with a Philips SHB7150 [ Philips SHB7150 ][1] [1]: p4c.philips.com/cgi-bin/dcbint/… – Laurent06000 Sep 22 '15 at 0:48
  • 1
    For those who had the same problem that I had (that the high fidelity playback does not work and cuts out all audio and applications that use this audio): this script solved the issue: askubuntu.com/a/864841/119445 – Peeperkorn Mar 7 '17 at 16:15
129
+50

Solution: Go into sound settings, then see what the SHB4000 is using. If it uses HSP/HFP change to A2DP.

  • 1
    It worked for my MPow too! – Fran Marzoa Aug 18 '16 at 11:30
  • 3
    Thanks. Just noting this worked for my Sony MDR-ZX770BN as well. – Nicholas Sep 30 '16 at 0:52
  • 1
    Seems I spoke too soon. When I change the settings from HSP/HFP to A2DP Sink, the sound cuts out and any applications which use sound stop working – Peeperkorn Mar 7 '17 at 15:49
  • 1
    This worked for me on Fedora 25. It temporarily re-routed things back through my desktop speakers, but I just swapped the Output Device back and forth a couple times and it started working perfectly. – Craig Otis May 11 '17 at 13:12
  • 1
    But for my Sony MDR-ZX770BN I can't change to A2DP: configuration not saved. Gubuntu 17.04 – demon101 Aug 18 '17 at 12:27
10

For those experiencing this with Ubuntu 16.04, and switching to A2DP only worked once, I had to disconnect, forget the device, reconnect, switch to A2DP, for it to start working again.

(Wanted to post this as a comment, but n00b-ness prevents this)

  • i added the below bluetooth config as per 56ka. didn't work this also nearly didn't work until I went back into audio and chose main speaker to be default then my current device boombar to be default again - it is a little flaky - and requires running through the sequences- – Vahid Dec 13 '18 at 15:07
  • dude! this saved me, thanks – Matías Cánepa Aug 15 at 14:02
6

Here is the solution that worked for me on Debian 9 (menu impossible to apply)

Important: you will have to restart bluetooth before each reconnection !

Source: https://unix.stackexchange.com/a/415928/325467


I am using a SoundBuds Curve headset in Debian 9, and have had the same problem, I was unable to switch from the HSP/HFP profile to the A2DP profile.

What fixed the issue for me, was editing /etc/bluetooth/main.conf

sudo nano /etc/bluetooth/main.conf

First add the following lines under the [General] tag (copied from audio.conf, I found searching for a solution):

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

Next you must enable support for multiple profiles (a few lines below) just uncomment and set value to multiple

MultiProfile = multiple

Then restart bluetooth service

sudo systemctl restart bluetooth 

Important: you will have to restart bluetooth before each reconnection !

  • The quality is now much better, but the microphone's gone :D – MonkeyMonkey Aug 8 at 11:34
2

I had to do both setting the main.conf to multiple profiles then remove the headphones and add them back and then they defaulted to High Fidelity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.