6

I have been trying to flash my BIOS to upgrade it to version A05, as suggested to me by Dell (since my computer has some bugs that make it unusable).

I created a FreeDOS disk with Unetbootin, copied the file from Dell on there; 9343_BIOS_Rev_A05.exe ; and when I boot the disk, the file doesn't seem to be on there.

I also read some people the image (I don't really have an image, but an exe file), in /boot/xxxx, but I use grub instead of sputnik's default.

I tried running the exe with wine to extract it, but it gives an error. Any ideas? I don't have a UEFI system.

  • Store the update binary on your EFI partition (/boot/efi) or on a USB flash drive, reboot, and choose BIOS Update in the F12 boot menu. This is from the generally excelent Arch Wiki wiki.archlinux.org/index.php/…. I have not tried it myself. – Bruni Sep 21 '15 at 10:15
  • 1
    Because my systems is not UEFI, it's not a duplicate of the refered to question. After a long search and trial process, I've eventually managed to do it like this dorienherremans.blogspot.co.uk/2015/09/… – dorien Nov 2 '15 at 13:00
  • Is it possible to invert or remove the "duplicate" tag? The answer given here is much better (at least for the Dell XPS 13) than for the question it is allegedly a duplicate of. – justfortherec Jun 25 '17 at 21:41
15

Only UEFI system method :

There is now an easier way to install BIOS update. Simply run :

wget http://downloads.dell.com/FOLDER03172775M/1/9343_BIOS_Rev_A05.exe
sudo cp 9343_BIOS_Rev_A05.exe /boot/efi/

Boot in your computer BIOS (hit F12 when Dell's logo is displayed) then select Bios Flash Update and the update will be installed.


Successfully tested on my XPS 13 (9343, 2015) with A05 update.

Successfully tested on XPS 13 (9350) with XPS_9350_1.3.3.exe, too.

(Inspired from Arch Linux Wiki)

  • I only have /boot/grub. Would that work too? – dorien Sep 21 '15 at 10:14
  • 1
    @dorien: if freedos doesn't work, wine doesn't work, and UEFI isn't available to you, you should talk to Dell again, as the only other way is to get a native Linux version... I would try renaming the file to BIOS-UPD.EXE under freedos when you save it there. – Fabby Sep 21 '15 at 10:42
  • 1
    Download the Windows BIOS 1.3.3 and install it performing described way above works for newer XPS13 (9350), too. – Christian Apr 18 '16 at 14:17
  • 1
    I can confirm this also works with the 9360 version (2016). – justfortherec Jun 25 '17 at 21:42
  • 1
    this totally worked for me - but i'm using debian 9.2. i wish i found this answer before the last 6 hours of trying to make a bootable windows usb to run the exe :/ – DAB Nov 18 '17 at 0:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.