I have a fresh installation of Ubuntu 14.04 on a Macbook Pro. I've also already tried reinstallting that Ubuntu another time. It's a single-boot system, i.e. I have no other operating systems installed.

Each time I start it, it boots to the GRUB prompt. Here all I have to do is to load the correct config:

configfile (hd2,gpt1)/EFI/grub/grub.cfg

This command starts the system without any further problems. How can I make GRUB start from this config automatically, i.e. without booting to prompt? I've already tried running update-grub and grub-install /dev/sda. They finish without errors, but don't make any change.

Here is some further information, in case its relevant:

  • mount | grep boot

    /dev/sda1 on /boot/efi type vfat (rw)

  • sudo parted -l

    Model: ATA Hitachi HTS54503 (scsi)
    Disk /dev/sda: 320GB
    Sector size (logical/physical): 512B/512B
    Partition Table: gpt
    Number  Start   End    Size    File system     Name  Flags
     1      1049kB  538MB  537MB   fat32                 boot
     2      538MB   316GB  315GB   ext4
     3      316GB   320GB  4150MB  linux-swap(v1)

  • sudo efibootmgr

    BootCurrent: 0000
    Timeout: 5 seconds
    BootOrder: 0000
    Boot0000* grub
    Boot0081* Mac OS X

1 Answer 1


After hours of headache, I stumbled over this forum post. Interestingly, the situation explained their is quite contrary to mine:

The problem is at least partially fixed. When dumped to the grub shell the "set" command is useful. It clearly showed the prefix as being set to "(hd0,gpt1)/boot/grub". This folder and the stub grub.cfg did not exist and instead the stub grub.cfg was in the /EFI/ubuntu folder in the EFI partition instead. I manually created /boot/grub/ in the EFI partition and copied the stub grub.cfg into it and that was all she took.

For me however, the prefix was .../efi/ubuntu but it should be efu/grub. To me, it really looks like this is an Ubuntu bug. The proper fix for this issue would be to change the prefix, but I also have no idea where it is coming form. TL;DR: So instead, as a work-around, I copied /boot/efi/EFI/grub to /boot/efi/EFI/ubuntu and voilà.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.