I have installed TeamViewer 10 in Ubuntu 14.04 and used it with mobile Internet (USB tethering). It worked well, but once I disconnected the mobile device and connected the system to an office Internet (LAN) with Internet access, it shows this error information: Not ready. Please check your connection. I have checked all proxy settings but nothing worked - I need to use my office system at home through TeamViewer. How should I proceed to make TeamViewer work on LAN?

7 Answers 7


Sometimes after switching the network connection (wired/wireless), TeamViewer service hangs.
To fix this - restart teamviewer service. Open a terminal and execute the following commands :

sudo teamviewer daemon stop
sudo teamviewer daemon start  

Alternatively you can restart the teamviewer service with : sudo teamviewer daemon restart
To check if the service was restarted successfully execute : sudo teamviewer daemon status

When it doesn't solve the problem, check if TeamViewer is blocked by the firewall of the router.
If you are working with an office system provided by a company, it may be blocked within there.

Additional information addressing the comments under the answer "Didn't work for me" :

Sometimes the installation of teamviewer by clicking the .deb file, which opens the Software Center, doesn't install the application including all required dependencies properly and hence fails.
Having installed and used TeamViewer successfully for many years, I can recommend to install TeamViewer by using the gdebi packaging tool, to install it execute sudo apt install gdebi. Right-click the .deb installation file and select to open it with gdebi - then start the installation.

Update December 2017 : TeamViewer 13 was released, for the first time as a native Linux client.
The installer added a TeamViewer repository which currently seems to be not correctly configured.
This may be due to the fact that TeamViewer 13 Linux is still only available as a preview edition. To avoid apt errors, I recommend to remove the repository and install new versions manually until the issue is fixed, to achieve this execute sudo rm /etc/apt/sources.list.d/teamviewer.list.

Update April 2018 : I've tested TeamViewer 13 on Ubuntu 18.04 LTS (running on Xorg) and the application installed correctly by clicking the .deb file. TeamViewer seems to work as expected.

Update August 2018 : TeamViewer 13 has left the preview state and became a regular product.

Update November 2018 : TeamViewer 14 was released and is being made available for Linux.

Users who experience problems with the new edition, may want to follow the discussions in the TeamViewer - Community TV General | Community TV Linux | Community TV TeamViewer 13.

  • Why is restarting sufficient?
    – A.B.
    Sep 20, 2015 at 13:09
  • As you're a reputation 1 user: If this answer helped you, don't forget to click the grey at the left of this text, which means [Yes, this answer is valid]askubuntu.com/help/…! ;-)
    – Ravan
    Sep 22, 2015 at 15:12
  • 20
    Didn't work for me.
    – thouliha
    Dec 14, 2015 at 15:37
  • Also didn't work for me (whatever I tried). What work for me: Don't use the .deb archive. Download the tar.xz. Extract it with tar xvf teamviewer_i386.tar.xz. And open the binary in a desktop environment (e.g. with vnc) ./teamviewer Only disadvantage: You have no teamviewer service running. They seem to have messed up the .deb file Jan 24, 2017 at 5:56
  • Its working for me. Feb 26, 2017 at 6:54

It did get to work in my case by running below commands in a terminal:

    sudo systemctl stop teamviewerd.service

    sudo systemctl start teamviewerd.service

The only way I could get this to work is to run it as portable.

  1. Download the .tar.xz version
  2. Uncompress it somewhere
  3. ./tv-setup checklibs (this will tell you if all dependencies are met)
  4. ./teamviewer

Give it some time to start, it feels slower to me than the packaged version.


You might be behind the proxy. if so go to Extras->options->general->proxySettings->configure.


I have resolved the issue by install the following package:

sudo apt install libnss-resolve:i386

& then:

sudo systemctl stop teamviewerd.service
sudo systemctl start teamviewerd.service

I was facing the same issue since I installed TeamViewer 14 on my Ubuntu 18. I was able to fix it by running the following command and restarting the machine.

sudo systemctl enable teamviewerd.service

I had the same problem here... it was caused by the DNS server used by the internet provider. Changing to any other made it work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.