4

I'm running Ubuntu as a guest on VirtualBox.
When I install NVIDIA (current) drivers for my GTX 670 and restart Ubuntu, it starts into a permanent login-crash window.

What's going on?

4

It is not a good idea to install video drivers to a guest system.

Guest systems do not have direct access to the graphics adapter. That is why they use virtual VBox drivers.

Just remove the Nvidia driver and never install it to guest systems.

If you did not do that already, install Guest Additions from Machine menu. This will install the virtual drivers.

  • Oh, thanks. Didn't know that. Learned something new. Any idea how to improve the graphic performance otherwise? Like different vbox drivers? – Grumpy ol' Bear Sep 20 '15 at 9:30
  • You need to install Guest Additions. These are the drivers. – Pilot6 Sep 20 '15 at 9:32
  • hi @Pilot6, I'm in reverse situation .. host is linux and guest is Win box,, I see that newer kernels will have direct access to GPU's, link: goo.gl/dGAa8z .. looking forward what future will bring us :) – Kresimir Pendic Jul 13 '17 at 10:18
1

I had recently installed Ubuntu 15.10 64-bit onto a USB thumb drive (not a Live USB!) and had trouble with running it on my laptop[1] natively and in VirtualBox interchangeably[2] while using nvidia-364 drivers. I experienced the login loop and several other problems after troubleshooting. My laptop has NVIDIA Optimus switchable graphics.

Selecting the "Intel (Power Saving Mode)" setting in the NVIDIA X Server Settings PRIME Profiles with my laptop before booting with VirtualBox solved this problem for me.

NVIDIA X Server Settings PRIME Profiles

Here is an answer about installing nvidia-prime.

Footnotes:

  1. Windows 8.1 64-bit host
  2. See this answer for more about booting USB drives in VirtualBox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.