3

I am on a 64bit system, that is what I suspect is creating this problem. I'm trying to install various packages, one of them is libssl-dev.

$ sudo apt-get install libssl-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2) but 1.0.1f-1ubuntu2.8 is to be installed
              Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried doing sudo apt-get -f install which is suggested in similar question on the site. But this is what I get:

$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I researched more on the site and someone suggested to installed the missing packages manually. So I did the same:

$ sudo apt-get install libssl1.0.0 Reading package lists... Done
Building dependency tree       
Reading state information... Done
libssl1.0.0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Here you can see, the package is already installed.

So my guess here is my system is trying to install 64bit version of libssl-dev but can't find 64bit version of libssl1.0.0. If manually installing, my system is showing that I have libssl1.0.0 which is suspect is 32bit version.

I have many more packages to install which are infected with this very bug.


Here are the output requested by @nephente

 $ uname -a
Linux sntsh-pc 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
 $ apt-cache policy libssl1.0.0 libssl-dev
libssl1.0.0:
  Installed: 1.0.1f-1ubuntu2.8
  Candidate: 1.0.1f-1ubuntu2.8
  Version table:
 *** 1.0.1f-1ubuntu2.8 0
        100 /var/lib/dpkg/status
     1.0.1f-1ubuntu2 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libssl-dev:
  Installed: (none)
  Candidate: 1.0.1f-1ubuntu2
  Version table:
     1.0.1f-1ubuntu2 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
 $ 
2
  • 1
    Could you add the output of the following: uname -a and apt-cache policy libssl1.0.0 libssl-dev
    – Nephente
    Sep 19 '15 at 8:42
  • Here you go @nephente Sep 19 '15 at 10:18
3

Force the downgrade of libssl1.0.0

sudo apt-get install libssl1.0.0=1.0.1f-1ubuntu2

The installed version 1.0.1f-1ubuntu2.8 blocks the installation of libssl-dev


And you should update your machine urgently. The curent version is 1.0.1f-1ubuntu2.15

Open Software & Updates and mark trusty-security and trusty-updates

enter image description here

After that

sudo apt-get update
sudo apt-get dist-upgrade

And no, sudo apt-get dist-upgrade doesn't install Vivid.

3
  • Beat me to it :-)
    – Nephente
    Sep 19 '15 at 11:21
  • @nephente Sorry :\
    – A.B.
    Sep 19 '15 at 11:23
  • No problem! It's a good anwer and it has pictures, too ;-)
    – Nephente
    Sep 19 '15 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.