2

Every time I download a file in Firefox with an unknown extension, Firefox offers to open it with Password Gorilla (default).

Firefox does show the proper application for known file types, e.g. pdf.

When the download is finished and I click on the file in the download list that Firefox maintains, it tries to open the file with Password Gorilla.

If I however open a file browser and then click on the file, it is opened using the proper application.

Password Gorilla is an application that I use to keep my passwords safe. I don't have a clue why it has become the default for all unknown file types. It should only be associated with .psafe3 file extensions.

How can I change or reset the default for unknown file types?

I'm using Firefox 40.0.3 under Ubuntu 14.04 and GNOME Shell 3.10.4.

2

Firefox used the application defined in

~/.local/share/applications/mimeapps.list

for type application/octet-stream under [Default Applications].

In my case it was like this :

[Default Applications]
application/octet-stream=geany.desktop

You can set it to another application. If you remove this line, firefox will used the one defined under [Added Associations].

If you remove also the application/octet-stream under [Added Associations], then firefox will give you only the option to save the file.

|improve this answer|||||
  • In my case, I removed all the lines, so now firefox only downloads the file. When I click on it in the download pop-up, it's gnome who handles the filetype and it usually open the right application. – Franperr Oct 6 '15 at 9:54
  • 2
    Since ubuntu 15.04 (and maybe 14.10), this file is now in ~/.config/mimeapps.list – Franperr Oct 13 '15 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.