First of all, I am well aware of this question: What's the easiest way to upgrade Ghostscript?.

Unfortunately none of the answers worked. I can find deb files from this list. There, I am surprised to see that the last version of Ghostscript for Ubuntu 14.04 is version 9.10. When I download version 9.15 for Ubuntu 15.04, and I run it (as root), I get the error:

Error: dependency is not satisfiable libgs9

I checked (apt-get install libgs9) and I have the latest libgs9 installed. Also, this site seems to confirm that last is version 9.10 for 14.04.

Does this mean it is not possible to upgrade Ghostscript?

1 Answer 1


What do you want to do is not possible. At least not without making your system broken.

You can't install the Vivid version of ghostscript in Trusty. The package has some dependencies and one of them is libgs9 (= 9.15+dfsg-0ubuntu2.1). The version for libgs9 in Trusty is libgs9 (9.10~dfsg-0ubuntu10.4). Therefore, forget it. :)

Repair your system via

sudo apt-get install -f

In the meantime you could try this PPA

sudo apt-add-repository ppa:anton+/photo-video-apps
sudo apt-get update
sudo apt-get install --reinstall ghostscript
  • 1
    So sad... That means I can't use Asymptote properly!!
    – anderstood
    Sep 18, 2015 at 19:26
  • 1
    If you like my answer, just click the little grey at the left-hand side of my answer, now turning it into beautiful green. If you do not like my answer, click on the little grey down-arrow below the 0, and if you really like my answer, click on the little grey checkmark and the little up-arrow... If you have any further questions, go to askubuntu.com/questions/ask ;)
    – A.B.
    Sep 18, 2015 at 19:27
  • 1
    You could install Vivid
    – A.B.
    Sep 18, 2015 at 19:28
  • I like your answer so I upvoted. But I am still waiting for other possible answer. If no better (= allowing me to upgrade only ghostscript) answer come, I will accept it!
    – anderstood
    Sep 18, 2015 at 19:33
  • Understand. Updated my answer.
    – A.B.
    Sep 18, 2015 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .