When I try to confirm than I can run Unity 3D on my Asus U31SD with intel's i5 Sandy Brigde and Nvidia 520 and Nvidia Optimus I receive this error: Xlib: extension "GLX" missing on display ":0".

Of course, I cannot run any of the effects of Ubuntu 11.10, not even the simple app switcher.

Can anybody help me? Thank you

6 Answers 6


This error occurs when you install the proprietary nvidia driver on NVidia Optimus laptop. The nvidia card cannot directly be used due to the Optimus design. To repair this, uninstall the nvidia-current package and re-login. After that, you'll solely be running off the Intel graphics card which renders the nvidia card unused though it'll still be using power. Bumblebee allows you to switch off the card, see Is a NVIDIA GeForce with Optimus Technology supported by Ubuntu?

  • I removed and purged nvidia-current but there is still the error "extension GLX missing on display :0".
    – H2ONaCl
    Aug 22, 2012 at 10:16
  • @broiyan If you have an Optimus laptop, please see the linked question.
    – Lekensteyn
    Aug 22, 2012 at 10:27
  • Yes, I have an Optimus card. I tried removing nvidia-current via the command line and still Ubuntu Software Center thinks it's installed. I tried various things at the link as well, including rebooting to uninstall the Nvidia 295.53 driver. Still I can't get glxspheres to run. My aim is to get 32 pixel icons in the Launcher and that's why I'm using Optimus.
    – H2ONaCl
    Aug 22, 2012 at 12:47
  • If you are using Bumblebee, you can try to get help from the IRC channel #bumblebee on Freenode IRC. Ensure that /etc/X11/xorg.conf is removed, that you have not installed the nvidia driver directly from nvidia.com and then reinstall Bumblebee using: sudo apt-get purge bumblebee bumblebee-nvidia nvidia-current && sudo apt-get install bumblebee. Reboot (or restart the DE) and try again.
    – Lekensteyn
    Aug 22, 2012 at 17:42

If I remember well GLX have something to do with OpenGL windowsing in X systems. So make sure you install mesa package which is implementation of OGL in Linux

  • 3
    Installed "mesa-vulkan-drivers" and the error was fixed!
    – Torrien
    Oct 4, 2018 at 5:01
  • actually, that helped Jan 8, 2019 at 8:25

Is that a system with 2 graphics cards? If so, the following makes google earth work for me: https://launchpad.net/~bumblebee/+archive/stable

As that page mentiones, you could always try experimental drivers, although that alone didn't solve my problems. Open a console and type:

add-apt-repository ppa:ubuntu-x-swat/x-updates

or, if you're feeling lucky, the latest-but-less-stable:

add-apt-repository ppa:xorg-edgers/ppa

then update the drivers

apt-get update
apt-get upgrade
apt-get install nvidia-current ppa-purge

and update /etc/X11/xorg.conf nvidia-xconfig

Note that the last step breaks my system. I have restore the old xorg.conf to make it work again:

cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

The 'driver' line in the 'device' section is what's giving me problems. For more details, see: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

and launchpad.net/~xorg-edgers/+archive/ppa


I have a Dell Latitude E6240 with nVidia card. Just this afternoon I noticed an optimus option in the bios which indicated it was only for Windows 7 32-64 bit, turned it of and voila. I have no more errors, Cheese Webcam Booth worked and certain features (probably Unity) started to work. (transparent windows, Expo/DesktopWall worked properly)


For the proper way to setup bumblebee, check the "power consumption" section on the Ubuntu wiki here (I just edited it in):


This question is a little old, but I put it here for people to find.


I have a NVIDIA GTX 550 ti in my computer and install the driver from nvidia.com. I encounter this issue when I finish upgrade operation

sudo apt-get upgrade

So I tried to reinstall the driver and it works.

sudo stop lightdm
sudo bash NVIDIA-Linux-x86_64-331.67.run

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .