2

I'm in the progress of migrating my linux server as my old one is quite thoroughly screwed. Not only are all the permissions screwed up, but my mysql server won't even start.

At first the error (what I think from what I read) was because /var/mysql was too full. I saw that I had used 19gb/20gb of my storage space, so I upgraded my storage to 45gb, but now it still won't start, and I can't find out why.

I don't really card if it starts or not, however I want to be able to get the databases off the server and onto my new one. However I'm having a hard time doing that also, so I want to be able to start the mysql server, and then just export to .sql and import.

root@vultr:~# sudo /etc/init.d/mysql start

sudo: unable to resolve host vultr.guest

Starting MySQL database server mysqld [fail]

I also tried just normal start:

root@vultr:~# service mysql start

start: Job failed to start

Storage on my machine:

Filesystem Size Used Avail Use% Mounted on
/dev/vda1 45G 19G 24G 45% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 991M 4.0K 991M 1% /dev
tmpfs 201M 364K 200M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1001M 0 1001M 0% /run/shm
none 100M 0 100M 0% /run/user

My var/logs/mysql/error.log: http://pastebin.com/bzg7km7L

What other commands should I run? or how can I find out what is going wrong and why isn't Mysql starting?

Please help, I've spent all morning trying everything....

0

The mysql files are located in /var/lib/mysql/. This folder has folders each of which is a database, inside of which are the tables. You should be able to simply "sudo cp -r /var/lib/mysql /usbflashdrive". Note, access to this folder requires super user. You will need to "sudo su" to access it.

This has been noted before.

0

You can also try mysqld_safe.

This is the preferred way to start The MySQL server on Linux.

Here is a reference to the docs: https://dev.mysql.com/doc/refman/5.6/en/mysqld-safe.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.