Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

After upgrading to Ubuntu 11.10, the following problems occurs when accesing in ubuntu mode (3D): the launcher is missing, top panel without icons on the right side, and I can only restart with Terminal (Alt-T and then sudo reboot). No problems in 2D. It occurs on my PC with AMD Athlon (tm) II X4 640 Processor, Radeon HD5670 and both with the 32-bit and 64 bits versions of Ubuntu. Both versions work well on an older PC with AMD Athlon 64 x2 Dual Core 4200 + processor, and an Nvidia integrated graphics card (C61 GeForce 6150SE nForce 430). Could it be a problem with the ATI driver?

marked as duplicate by Jorge Castro, Nitin Venkatesh, fossfreedom Feb 23 '12 at 16:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you please post the output of this command: /usr/lib/nux/unity_support_test -p? – fitojb Oct 16 '11 at 15:09
  • I'm sorry for the delay.jlotero2@cristina-GA-MA78LMT-S2:~$ /usr/lib/nux/unity_support_test -p OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: ATI Radeon HD 5670 OpenGL version string: 4.1.11005 Compatibility Profile Context Not software rendered: yes Not blacklisted: yes GLX fbconfig: yes GLX texture from pixmap: yes GL npot or rect textures: yes GL vertex program: yes GL fragment program: yes GL vertex buffer object: yes GL framebuffer object: yes GL version is 1.4+: yes Unity 3D supported: yes – jlotero Oct 16 '11 at 15:32
  • Closed - since OP has confirmed that the dupe link is the resolution (see comment below answer) – fossfreedom Feb 23 '12 at 16:13

So it seems that your computer is capable of running Unity 3D.

Try this answer in another question:

ctrl-alt-T for a terminal and run cssm

re-enable your 'unity' plugin

you also may then need to run a

unity --reset

If you don’t have CCSM installed, run sudo apt-get install compizconfig-settings-manager

  • 1
    Solved! I think the problem arose after trying to reduce the size of the icons in Launcher (with ccsm). Although I finally decided to keep the default size, the Ubuntu Unity plugin remained disabled. After re-run ccsm as advised, to try to re enable it, appeared several dialogues (in spanish, the version I'm using). The first: – jlotero Oct 17 '11 at 0:58
  • 1
    Some of the key links and the edge of Ubuntu Unity Plugin Plugin conflicts occur with other plugins. Do you want to solve? -Ignoring conflicts -Resolve Conflicts (selected) Then came another 5 dialogues, with the options: Ignore and apply ... (the choice of reference) They do not apply ... (reference option) Off ... (reference option) In all these cases, I selected the first option. Then the Ubuntu Unit plugin re-enabled, and now everything works perfectly. (for more details of each dialogue, see paste.ubuntu.com/710381/) Thank you very much for your help. – jlotero Oct 17 '11 at 1:03
  • OK, so the problem was in fact that Unity plugin was disabled. And the dialogs that appeared are “conflicts” of Unity plugin with other Compiz plugins. I’m glad you solved it! Saludos – fitojb Oct 17 '11 at 10:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.