Whenever I boot, it show Plymouth then goes to a screen full of boot log, I -think- the only relevant part is Starting Wait for Plymouth Boot Screen to Quit...es.ileged Tasks.s..p link was shut down... (If someone know where this file is logged, I can upload it, I copied this by hand. Everything else is over SSH) It had been going to to this then low graphics mode with Nvidia drivers, and it booted properly without them, but after I messed around with I only get this. I can get to the terminal with ctrl+alt+1, so I tried to re-run lightdm, and I got this:

aidan@cinnabar:~$ sudo lightdm
[sudo] password for aidan:
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf

These are the contents of modprobe.d:

aidan@cinnabar:~$ ls /etc/modprobe.d/
alsa-base.conf           blacklist-framebuffer.conf   blacklist-watchdog.conf         iwlwifi.conf
blacklist-ath_pci.conf   blacklist-modem.conf         dkms.conf                       mlx4.conf
blacklist.conf           blacklist-oss.conf           fbdev-blacklist.conf            vmwgfx-fbdev.conf
blacklist-firewire.conf  blacklist-rare-network.conf  intel-microcode-blacklist.conf

I also tried to run sudo service lightdm restart, and it gave me Job for lightdm.service failed. See "systemctl status lightdm.service" and "journalctl -xe" for details.

output of systemctl status lightdm.service:

aidan@cinnabar:~$ systemctl status lightdm.service
● lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/display-manager.service.d
   Active: failed (Result: start-limit) since Thu 2015-09-17 21:02:58 CDT; 1min 13s ago
     Docs: man:lightdm(1)
  Process: 2299 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
  Process: 2294 ExecStartPre=/bin/sh -c [ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 2299 (code=exited, status=1/FAILURE)

Sep 17 21:02:58 cinnabar systemd[1]: lightdm.service failed.
Sep 17 21:02:58 cinnabar systemd[1]: lightdm.service holdoff time over, scheduling restart.
Sep 17 21:02:58 cinnabar systemd[1]: start request repeated too quickly for lightdm.service
Sep 17 21:02:58 cinnabar systemd[1]: Failed to start Light Display Manager.
Sep 17 21:02:58 cinnabar systemd[1]: Unit lightdm.service entered failed state.
Sep 17 21:02:58 cinnabar systemd[1]: Triggering OnFailure= dependencies of lightdm.service.
Sep 17 21:02:58 cinnabar systemd[1]: lightdm.service failed.

Output of journalctl -xe on pastebin here.

I'm happy to provide anything else! If anyone know's whats wrong, i'd be really grateful.


  • MSI GE70 2PE Apache Pro
  • Nvidia 860M
  • did you solve this issue? – tokam Nov 23 '15 at 17:08
  • @tokam I ended up reinstalling, sorry. – Aido Nov 30 '15 at 23:31

For me the analisis of: "cat /var/log/lightdm/x-0-greeter.log" showed that I had to create the lightdm directory. It was missing. After running the following commands I fixed my machine.

mkdir -p /var/lib/lightdm
chown -R lightdm:lightdm /var/lib/lightdm
chmod 0750 /var/lib/lightdm

I had a similar problem, which I solved by downloading the most current driver from NVIDIA and installing it.


  • 1
    The OP also said the problem was solved by reinstalling. – WinEunuuchs2Unix Apr 15 '18 at 22:28
  • I just saw that in the comments. Thanks for pointing it out! – blackappy Apr 17 '18 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.