0

I have a Lenovo S series running Windows 8.1 (pre-installed). I downloaded Ubuntu 15.04 onto a USB stick and followed the instructions as outlined in the Quick Install From USB docs.

Secure Boot is disabled.

I can successfully boot into Ubuntu and begin the installation process. Around 80% of the way through I get the fatal error:

unable to install GRUB in /dev/sda

I've been through many of the other posts here on this issue, but cannot find a solution that seems to work in my situation. I have tried the 'Try without installing' option, and attempting to install after booting to desktop, but I get the same problem.

As far as I can tell, the issue is with the partition that is being attempted to install to.

Update: Boot Info here: http://paste.ubuntu.com/12447125/

Is anyone able to offer any advice on what might be causing this, or how I should choose/prepare a partition in order to install successfully?

Thanks

  • 2
    Are you installing in BIOS mode on gpt partitioned drive. Better to install in UEFI mode. Then it will use existing ESP - efi system partition. Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Sep 17 '15 at 21:59
  • Try running Boot-Repairs fixes. You show signed kernels installed which should work with either Secure boot on or off. There used to be some systems with "locked" ESP - efi system partition. Some repaired with chkdsk from Windows or dosfsck sudo dosfsck -t -a -w /dev/sda2 from Linux. Others had to totally back up ESP, erase it, then recreate with gparted as FAT32 with boot flag or using gdisk code ef00 so it is the new ESP and restore files. – oldfred Sep 18 '15 at 15:06
  • Thanks, I'm slightly out of my depth here - boot-repair fixes seem to suggest: "reinstall grub-efi-amd64-signed of sda7 with sda2/boot/efi option". How would I go about doing this? – duncanhall Sep 18 '15 at 15:31
  • I ran dosdsck which found 1 dirty bit. I ran apt-get install grub-efi-amd64-signed and then tried the install again (complete wipe and install), which failed with the same problem. I'm assuming perhaps I need to 'reinstall ubuntu' without wiping, after having run the install grub command? – duncanhall Sep 18 '15 at 15:53
  • You should not have to reinstall Ubuntu. Did you get error message on the install of grub? Only use Something Else on reinstall if you do that. It may say overwriting Ubuntu, but erase entire drive. Supposedly that was fixed, but depends on version you are using. – oldfred Sep 18 '15 at 17:26
1

First, disable Fast Startup in Windows. This feature is a good way to cause filesystem corruption (my nickname for it is "Fast Filesystem Corruption"), which in turn can cause any number of problems, including an inability to install GRUB -- precisely the symptom you're seeing.

After you've disabled Fast Startup, you can try running Boot Repair or re-install Ubuntu. With any luck, disabling Fast Startup will enable either of these procedures to work, but I can't make any promises about that.

If you disable Fast Startup but can't seem to get GRUB installed, another option is to try my rEFInd boot manager. You can try it risk-free by preparing a USB flash drive or CD-R with the appropriate version (see the downloads page for links). You should then be able to boot from the appropriate medium, which should let you boot either Windows or Ubuntu. If you can boot both OSes, you can install rEFInd via the PPA or Debian package to get it on your hard disk. One big caveat is that if there's filesystem damage that's preventing GRUB from installing, the same problem is likely to affect rEFInd. OTOH, it could be a bug in the GRUB installation script that's not shared by the rEFInd installation script, so rEFInd might work around such problems. If nothing else, using rEFInd on a USB drive or CD-R might be a useful temporary stopgap to get you into your regular Ubuntu installation. From there you'd need to do more detailed analysis to figure out what's causing the boot loader problems, but at least you'd have a way to boot.

| improve this answer | |
0

The solution in my case was to enable the 'Both' option for UEFI/Legacy BIOS boot support, as well as setting the Secure Chip to 'Inactive'. After all previous failed attempts, I made the changes to both these settings at the same time, so it's possible only one of them was required to solve the issue.

| improve this answer | |
-1

You are having problems with windows 8.1 secure boot. Try disabling UEFI following this tutorial. And then install Ubuntu.

| improve this answer | |
  • Thanks, I should've mentioned that Secure Boot is already disabled. – duncanhall Sep 18 '15 at 8:54
  • 1
    Secure Boot problems normally manifest as an inability to boot into the installer at all. Secure Boot is designed to block pre-boot malware from booting at all. I've never heard of a Secure Boot problem enabling the installer to boot and run through to the point of installing the boot loader and then failing, and in fact the way it works, that symptom seems completely improbable. Also, "disabling UEFI" is entirely the WRONG thing to do in this situation, since Windows and Linux must boot in the same mode. – Rod Smith Sep 18 '15 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.