1

I am on Ubuntu 15.04 using xfce (xubuntu) and am having trouble with my wi-fi. The indicator continues to show that I am connected to the network but after some amount of time I will no longer have internet access. In order to fix the issue I simply disconnect from the network and reconnect which always resolves it. I have had this issue occur on different networks.

03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
    Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
    Kernel driver in use: iwlwifi
5

Run in terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1 swcrypto=1 bt_coex_active=0 power_save=0"

and reboot.

In many cases only 11n_disable=8 is sufficient.


Explanation:

The iwlwifi Linux kernel driver supports several Intel wireless LAN adapters. The command adds the following configuration to the iwlwifi module:

11n_disable=1      Disables the 802.11n mode
11n_disable=8      Enables agg TX option
swcrypto=1         Disables hardware encryption and uses software instead.
bt_coex_active=0   Disables bluetooth coexistence technology that works poorly with iwlwifi
power_save=0       Disables the power save mode

To restart the services without rebooting to test alternative configurations:

sudo modprobe -r iwldvm iwlwifi
sudo modprobe iwldvm iwlwifi
sudo service network-manager restart

The shorthand command additionally uses a here string via the <<< operator in Bash to append these characters to the configuration file.

| improve this answer | |
  • I made this change and restarted but am still having the same issue – Matt Meinzer Sep 18 '15 at 2:07
  • Do you use bluetooth? – Pilot6 Sep 18 '15 at 9:49
  • No. There's no bluetooth daemon running from what I can tell – Matt Meinzer Sep 18 '15 at 15:08
  • @user3330797 I updated the command. – Pilot6 Sep 18 '15 at 15:10
  • Ok I made the change and rebooted. Had plymouth crash on start up but I'm not sure if that's related – Matt Meinzer Sep 18 '15 at 15:16
1

Router Side

In my case, despite the fixes suggested above, it turns out that my 6205 adapter could not handle an access point that allowed dynamic steering between 2.4/5 Ghz (called SmartSteering - specific to my router). I had to shut of dual banding in my router settings and change the AP to a 5 Ghz signal. This fixed the disconnection issues for me.

Laptop Side

It's possible to change this on the laptop side, but I haven't tested this (say, when you can't access router settings). The relevant nm-connection-editor setting would be changing the Band from automatic to a specific Band.

EDIT: I switched my router back to dual banding, and edited my connection to ONLY connect to the 5 Ghz band. It's gone the longest so far without disconnecting so I believe this is a plausible solution as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.